PAT自主训练记录 甲级1044 Shopping in Mars

A1044 Shopping in Mars (25分)

题目描述

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).
Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤ 1 0 5 10^5 105), the total number of diamonds on the chain, and M (≤ 1 0 ​ 8 10^​8 108​​), the amount that the customer has to pay. Then the next line contains N positive numbers D ​ 1 D​_1 D1​⋯ D ​ N D_​N DN​​ ( D i D_i Di 1 0 3 10^3 103​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that D i D_i Di + … + D j D_j Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that D i D_i Di + … + D j D_j Dj >M with ( D i D_i Di + … + D j D_j Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5


题目大意

给出一个数字序列与一个数S,在数字序列中求出所有和值为S的连续子序列(区间下标左端点小的先输出,左端点相同时右端点小的先输出)。若没有这样的序列,求出和值恰好大于S的子序列(即在所有和值大于S的子序列中和值最接近S)。假设序列下标从1开始。

思路
这次太菜了,一开始完全想不到应该怎么做,后来想着用结构体,把序号存起来,然后按照值递增排序做。可是题目要的是连续子序列,这样做肯定不行,就直接看书了
用sum[i]表示D[1]到D[i]的和值,即sum[i]=D[1]+D[2]+…+D[i]。那么sum[i]一定是严格递增的。
那么要求连续子序列D[i]到D[j]的和值,只需要计算sum[j]-sum[i-1]即可
因为sum[i]严格递增,所以可以用二分法来做
假设需要在序列D[1]~D[n]寻找和值为S的连续子序列,就枚举左端点,然后在sum数组 [i,n] 范围内查找值为sum[i-1]+S的元素是否存在。
(因为sum[j]-sum[i-1]=S,表示D[i]到D[j]的连续子序列的和值)

  • 如果存在,则把对应的下标作为右端点 j;
  • 如果不存在,找到第一个使和值超过S的右端点 j。

这个思路菜鸡我刚看到真的觉得好妙啊!将原本无序的数组巧妙地转化为用一个严格递增的数组来求解,将找多个数转变成找一个数是否存在

注意点

  • 使用 cin 和 cout 可能会超时,用 scanf 和 printf
  • 需要对序列遍历两次,第一次遍历求出≥S的最接近S的和值nearS(即无论最后是刚好给够还是多给一点,都将给的值赋给nearS),第二次遍历找到那些和值恰好为nearS的方案并输出。
  • 几组易错的数据
//input
3 3
1 2 3
//output
1-2
3-3

//input
3 5
2 2 2
//output
1-3

//input
1 10
//output
1-1

最终正确代码

#include<stdio.h>
#include<cstdio>
#include<iostream>
#include<algorithm>
#define MAXN 100001
using namespace std;

int N,M;
int nearM=100000001;
int sum[MAXN];


//[L,R)内第一个大于x的数
int binaryFind(int L,int R,int x){
    int left=L,right=R,mid;
    while(left<right){
        mid=(left+right)/2;
        if(sum[mid]>x){
            right=mid;
        }
        else{
            left=mid+1;
        }
    }
    return left;
}


int main(){
    scanf("%d%d",&N,&M);
    sum[0]=0;
    for(int i=1;i<=N;i++){
        scanf("%d",&sum[i]);
        sum[i]+=sum[i-1];//每个sum[i]记录的是从sum[1]到sum[i]的和
    }
    for(int i=1;i<=N;i++){
        int j=binaryFind(i,N+1,sum[i-1]+M);
        if(sum[j-1]-sum[i-1]==M){//j找到的是第一个大于的位置,所以这里判断的时候用的是j-1
            nearM=M;//一旦找到能够刚好凑成M的情况则跳出循环,重新遍历找到所有刚好凑够的情况
            break;
        }
        else if(j<=N&&sum[j]-sum[i-1]<nearM){
            nearM=sum[j]-sum[i-1];//更新最近的情况
        }
    }
    for(int i=1;i<=N;i++){
        int j=binaryFind(i,N+1,sum[i-1]+nearM);
        if(sum[j-1]-sum[i-1]==nearM){
            printf("%d-%d\n",i,j-1);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值