【PAT(甲级)】1044 Shopping in Mars(滑动窗口)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤105), the total number of diamonds on the chain, and M (≤108), the amount that the customer has to pay. Then the next line contains N positive numbers D1​⋯DN​ (Di​≤103 for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

解题思路:

我一开始的思路是用滑动窗口直接开始相加,然后判断是否大于M。为什么不用vector呢,因为我记得在哪里看到过,vector耗时比一般数组大,所以想省时间来着。结果写完之后一看别人代码,发现我冗余的厉害,跟个二傻子一样。

然后,这种连续相加的最长子区间的算法,一般都是求和存储,然后相减得出区间的,这样会节省很多时间。但光这样这题还是会超一个测试点,所以要设置一个temp来记录移动的位置,下次直接从temp这里开始减就行。

因为存储数组的前缀和,所以数组大小最好是开[N+1]个,第一个数组为0,这样会比较方便地输出下标。

易错点:

1. 主要是超时的问题,网络上其实还有很多方法,比如二分法,动态规划啥的;

2. 我遇到的难点就是第一个数组前缀和要为0,不然相减的时候,容易找不到最小的大于M的值;

3. maxmin记得设置的大一些,不然有个测试点会过不去。

代码:

#include<bits/stdc++.h>
using namespace std;
int N,M;

int flag = 0;
int main(){
	cin>>N>>M;
	int number[N+1]={0};
	for(int i=0;i<N;i++){
		int t ;
		cin>>t;
		if(i == 0){
			number[i+1] = t;
		}
		else{
			number[i+1] = t+number[i];
		}
	}
	
	int temp = 0;int maxmin = 99999999;
	for(int i=1;i<=N;i++){
		if(number[i]<M) continue;
		else if(number[i] >= M){
			for(int j=temp;j<i;j++){
				if(number[i]-number[j] == M){
					flag = 1;
					cout<<j+1<<"-"<<i<<endl;
					temp = j;
					break;
				}
				else if(number[i]-number[j] > M&&number[i]-number[j]<maxmin){
					maxmin = number[i]-number[j];
				}
				else if(number[i]-number[j] < M){
					temp = j-1;
					break;
				}
			}
		}
	}
	
	temp = 0;
	if(flag == 0){
		for(int i=1;i<=N;i++){
			if(number[i]<maxmin) continue;
			else if(number[i] >= maxmin){
				for(int j=temp;j<i;j++){
					if(number[i]-number[j] == maxmin){
						cout<<j+1<<"-"<<i<<endl;
						temp = j;
						break;
					}
					else if(number[i]-number[j] < maxmin){
                   	temp = j-1;
						break;
					}
				}
			}
		}
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值