九度OJ 1002

66 篇文章 1 订阅
27 篇文章 0 订阅
题目描述:

    Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other, a judge is invited to make the final decision. Now you are asked to write a program to help this process.
    For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:
    • A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem's grade will be the average of G1 and G2.
    • If the difference exceeds T, the 3rd expert will give G3.
    • If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem's grade will be the average of G3 and the closest grade.
    • If G3 is within the tolerance with both G1 and G2, then this problem's grade will be the maximum of the three grades.
    • If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

输入:

    Each input file may contain more than one test case.
    Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

输出:

    For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

样例输入:
20 2 15 13 10 18
样例输出:
14.0

题目大意:在高考阅卷中,同一份卷子有多个老师批改,给定满分值和差值,如果两个老师评分在差值之内,最终分数为两者平均数;在差值之外的话,再由第三个老师评分,分以下几种情况:1,第三个老师改的分数和某一个老师改的分数在差值之内,这里只是其中的一个老师,那么取第三个老师和其中最相邻的分数的平均数 2,第三个老师改的分数和两个老师改的分数都在差值之内,那么最终分数取三个老师评的最高的分数。 其他情况的话,最终分数为第四个老师就是judge来给分

#include <iostream>
#include <iomanip>
#include <cstdlib>
using namespace std;

int main(){
    int P,T,G1,G2,G3,GJ;
    while(cin>>P>>T>>G1>>G2>>G3>>GJ){
        double finalGrade;
        if(abs(G1-G2)<=T){
            finalGrade = (G1+G2)/2.0;
        }
        else if(abs(G1-G3)<=T&&abs(G2-G3)<=T)
            finalGrade = max(G1,max(G2,G3));
        else if(abs(G1-G3)<=T&&abs(G2-G3)>T)
            finalGrade = (G1+G3)/2.0;
        else if(abs(G2-G3)<=T&&abs(G1-G3)>T)
            finalGrade = (G2+G3)/2.0;
        else{
            finalGrade = GJ;
        }
        cout<<setprecision(1)<<fixed<<finalGrade<<endl;
    }
    return 0;
}

这里有我出现了好几次错误,第一点是 头文件的问题,如果用了abs()取绝对值的话,就要用#include <cstdlib> 如果是用<cmath>用产生歧义,这里特指用gcc编译器会发生这种错误。
第二点是,求平均数的时候,因为设计到小数,所以分母要改成2.0,这样得出的数才是我们要求的数。如果用2的话,产生的后果是,先进行截断,再进行强转成double,导致小数都是.0的形式,不符合要求。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值