HDU1171 Big Event in HDU(多重背包)

题目描述

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don’t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 – the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input
2
10 1
20 1
3
10 1 
20 2
30 1
-1
Sample Output
20 10
40 40
分析

根据分析,本题是n件物品,对应价值v和个数m,求一半总价值的最大值,是多重背包问题。
可以使用二进制优化多重背包加快运算速度。

C++ 代码
#include<bits/stdc++.h>
using namespace std;
const int N = 1e4+10;
int f[N*10],w[N],n,a,c;
int main()
{
	ios::sync_with_stdio(false);
	while(cin>>n)
	{
		if(n<=0) break;
		int sum=0,co=0;
		memset(f,0,sizeof f);
		for(int i=0;i<n;i++)
		{
			cin>>a>>c;
			sum+=(c*a);
			for(int k=1;k<=c;k*=2)    //每个物品划分为二进制形式  
			{
				w[co++]=a*k;
				c-=k;
			}
			if(c) w[co++]=a*c;
		}
		int v=sum/2;                //要求一半的体积下的最大值
		for(int i=0;i<co;i++)       //二进制优化后就变成了0-1背包问题
		{
			for(int j=v;j>=w[i];j--)
				f[j]=max(f[j],f[j-w[i]]+w[i]);
		}
		cout<<max(sum-f[v],f[v])<<" "<<min(sum-f[v],f[v])<<endl;    //输出此时的最大值和最小值
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Jay_fearless

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值