hdu-1171Big Event in HDU(多重背包的简单应用)

原文:
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don’t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 – the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
Sample Input
2
10 1
20 1
3
10 1
20 2
30 1
-1
Sample Output
20 10
40 40
题意描述:
以价值为依据尽可能的将器材平均分为两份,如果不行的话就让第一分大于第二份
解题思路:
实际上这还是一个完全背包问题,只不过是换了一种说法,最大容量变成了器材价值的一半,价值也变成了它所占据的空间,然后依然套用完全背包的公式就可以
AC代码:

#include<stdio.h>
#include<string.h>
#define max(a,b) a>b?a:b
int v[200005],num[200005],dp[200005];
int n,m;
int main()
{
  int i,j,k;
  while(scanf("%d", &n)!=EOF)
  {
  	memset(dp,0,sizeof(dp));
  	if(n<=0)
  	break;
  	int sum=0;
  	for(i=1; i<=n; i++)
  	{
  		scanf("%d %d", &v[i],&num[i]);
  	}
  	for(i=1; i<=n; i++)
  	sum+=v[i]*num[i];
  	int t=sum/2;//最大容量是一半
  	for(i=1; i<=n; i++)
  	{
  		for(j=1; j<=num[i]; j++)//每种器材的个数
  		{
  			for(k=t; k>=v[i]; k--)
  			  dp[k]=max(dp[k],dp[k-v[i]]+v[i]);
  		}
  	}
  	  printf("%d %d\n", sum-dp[t],dp[t]);
  	  //分的时候可能会装不满,只能是小
  	  //于等于一半所以sum减去分的才是>=已分的;
  }
  return  0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

皮皮皮皮皮皮皮卡乒

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值