HDU1237 简单计算器

75 篇文章 0 订阅

简单计算器

Problem Description

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

Input

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

Output

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

Sample Input

1 + 2
4 + 2 * 5 - 7 / 11
0

Sample Output

3.00
13.36

——————————————————————————————————————————————————

先把乘除算了,在整体算加,减当负处理,循环两遍

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
using namespace std;

int main()
{
    char str, c;
    double a, b;
    stack <double> num;
    while (scanf("%lf", &a) != EOF)
    {
        while (!num.empty())
            num.pop();
        c = getchar();
        if (c == '\n' && a == 0)
            break;
        num.push(a);
        scanf("%c", &c);
        while (scanf("%lf", &b))
        {
            if (c == '*')                
            {
                a = num.top();
                num.pop();
                num.push(a * b);
            }
            else if (c == '/')         
            {
                a = num.top();
                num.pop();
                num.push(a / b);
            }
            else if (c == '+')          
                num.push(b);
            else if (c == '-')          
                num.push(-b);
            c = getchar();
            if (c == '\n')              
                break;
            scanf("%c", &c);
            getchar();
        }
        double ans = 0.0;
        while (!num.empty())
        {
            ans += num.top();
            num.pop();
        }
        printf("%.2lf\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值