hdu5883 The Best Path

The Best Path

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 798    Accepted Submission(s): 332


Problem Description
Alice is planning her travel route in a beautiful valley. In this valley, there are  N  lakes, and  M  rivers linking these lakes. Alice wants to start her trip from one lake, and enjoys the landscape by boat. That means she need to set up a path which go through every river exactly once. In addition, Alice has a specific number ( a1,a2,...,an ) for each lake. If the path she finds is  P0P1...Pt , the lucky number of this trip would be  aP0XORaP1XOR...XORaPt . She want to make this number as large as possible. Can you help her?
 

Input
The first line of input contains an integer  t , the number of test cases.  t  test cases follow.

For each test case, in the first line there are two positive integers  N (N100000)  and  M (M500000) , as described above. The  i -th line of the next  N  lines contains an integer  ai(i,0ai10000)  representing the number of the  i -th lake.

The  i -th line of the next  M  lines contains two integers  ui  and  vi  representing the  i -th river between the  ui -th lake and  vi -th lake. It is possible that  ui=vi .
 

Output
For each test cases, output the largest lucky number. If it dose not have any path, output "Impossible".
 

Sample Input
  
  
2 3 2 3 4 5 1 2 2 3 4 3 1 2 3 4 1 2 2 3 2 4
 

Sample Output
  
  
2 Impossible
 



题目的意思是遍历所有边,算出每个经历过的点异或起来最大值

首先并查集算出集合数,大于1不可能;然后判欧拉回路,若度为奇的大于2,则不可能,若度为奇的等于二,则路线固定,其所经历所有点,若等于零则枚举起点

这里有个小技巧,a^a=0,0^a=a 所以异或时重复经历的点只要判经历次数是否为奇数即可

另外有个坑的是位运算优先级较低,你写

for(int i=1; i<=n; i++)
                {
                    if(ans^a[i]>mx)
                        mx=ans^a[i];
                }
就会wa,它先会判断>再异或




#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define inf 0x3f3f3f3f
#define mod 10000007
#define maxn 100005

int a[maxn];
int p[maxn];
int pre[maxn];
int n,m,sz;

int fin(int x)
{
    if(x != pre[x])
        pre[x] = fin(pre[x]);
    return pre[x];
}

void unio(int x,int y)
{
    int x1=fin(x);
    int x2=fin(y);
    if(x1!=x2)
    {
        pre[x1]=x2;
        sz--;
    }
}

int main()
{
    int o,u,v;
    while(~scanf("%d",&o))
    {
        while(o--)
        {
            scanf("%d%d",&n,&m);
            for(int i=1; i<=n; i++)
            {
                scanf("%d",&a[i]);
            }
            memset(p,0,sizeof(p));
            for(int i=1; i<=n; i++)
            {
                pre[i]=i;
            }
            sz=n;

            for(int i=0; i<m; i++)
            {
                scanf("%d%d",&u,&v);
                unio(u,v);
                p[u]++;
                p[v]++;
            }

            if(sz>1)
            {
                printf("Impossible\n");
                continue;
            }

            int tot=0;
            for(int i=1; i<=n; i++)
            {
                if(p[i]%2==1)
                    tot++;
            }
            if(tot>2)
            {
                printf("Impossible\n");
            }
            else if(tot==2)
            {
                int ans=0;
                for(int i=1; i<=n; i++)
                {
                    if(((p[i]+1)/2)%2)
                        ans=ans^a[i];
                }
                printf("%d\n",ans);
            }
            else
            {
                int ans=0;
                for(int i=1; i<=n; i++)
                {
                    if(((p[i]+1)/2)%2) ans=ans^a[i];
                }
                int mx=0;
                for(int i=1; i<=n; i++)
                {
                    mx=max(mx,ans^a[i]);
                }
                printf("%d\n",mx);
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值