团体程序设计天梯赛L3-010 是否完全二叉搜索树

L3-010. 是否完全二叉搜索树

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

将一系列给定数字顺序插入一个初始为空的二叉搜索树(定义为左子树键值大,右子树键值小),你需要判断最后的树是否一棵完全二叉树,并且给出其层序遍历的结果。

输入格式:

输入第一行给出一个不超过20的正整数N;第二行给出N个互不相同的正整数,其间以空格分隔。

输出格式:

将输入的N个正整数顺序插入一个初始为空的二叉搜索树。在第一行中输出结果树的层序遍历结果,数字间以1个空格分隔,行的首尾不得有多余空格。第二行输出“YES”,如果该树是完全二叉树;否则输出“NO”。

输入样例1:
9
38 45 42 24 58 30 67 12 51
输出样例1:
38 45 24 58 42 30 12 67 51
YES
输入样例2:
8
38 24 12 45 58 67 42 51
输出样例2:
38 45 24 58 42 12 67 51
NO

————————————————————————————————————

大体思路:根据题目所给意思建立二叉树,层次遍历,判断是否完全

数组模拟写法:

#include<map>  
#include<set>  
#include<ctime>  
#include<cmath>  
#include<queue>  
#include<bitset>  
#include<string>  
#include<vector>  
#include<cstdio>  
#include<cstring>  
#include<iostream>  
#include<algorithm>  
#include<functional>  
using namespace std;  
#define inf 0x3f3f3f3f  

int tree[10000000];
int n,mx;

void build(int x)
{
	int pos=1;
	while(tree[pos]!=-1)
	{
		if(x>tree[pos])
		pos*=2;
		else
		pos=pos*2+1;
	}
	tree[pos]=x;
	mx=max(mx,pos);
}

int main() 
{
int a[100];
scanf("%d",&n);
for(int i=0;i<n;i++)
{
	scanf("%d",&a[i]);
}
memset(tree,-1,sizeof tree);
mx=0;
for(int i=0;i<n;i++)
{
	build(a[i]);
}
int cnt=0,q=0;
for(int i=1;i<=mx;i++)
{
	if(tree[i]!=-1)
	{
		if(q++)
		printf(" ");
		printf("%d",tree[i]);
	}
	else
	{
		cnt++;
	}
	
	
}
printf("\n");
if(cnt==0)
printf("YES\n");
else
printf("NO\n");


	return 0;
}





数组模拟链表:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
using namespace std;

struct node
{

    int data,lch,rch;

} tree[100];
int n,pos;
void build(int a)
{
    int k=0;
    while(1)
    {
        if(a>tree[k].data)
        {
            if(tree[k].lch==-1)
            {
                tree[++pos].data=a;
                tree[k].lch=pos;
                break;
            }
            else
            {
                k=tree[k].lch;
            }
        }
        else
        {
            if(tree[k].rch==-1)
            {
                tree[++pos].data=a;
                tree[k].rch=pos;
                break;
            }
            else
            {
                k=tree[k].rch;
            }
        }
    }
}

void bfs()
{
    queue<int>q;
    q.push(0);
    int f;
    int qq=0;
    int flag=0,fl=0;
    while(!q.empty())
    {
        f=q.front();
        q.pop();
        if(f==-1)
        {
            flag=1;
        }
        else
        {
            if(qq++)
                printf(" ");
            printf("%d",tree[f].data);
            q.push(tree[f].lch);
            q.push(tree[f].rch);
            if(flag==1)
                fl=1;
        }
    }
    if(fl==1)
        printf("\nNO\n");
    else
        printf("\nYES\n");
}

int main()
{
    int a;
    scanf("%d",&n);
    memset(tree,-1,sizeof tree);
    pos=0;
    scanf("%d",&tree[0].data);
    for(int i=1; i<n; i++)
    {
        scanf("%d",&a);
        build(a);
    }
    bfs();

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值