ZOJ3768 Continuous Login

20 篇文章 0 订阅
14 篇文章 0 订阅
Continuous Login

Time Limit: 2 Seconds       Memory Limit: 131072 KB       Special Judge

Pierre is recently obsessed with an online game. To encourage users to log in, this game will give users a continuous login reward. The mechanism of continuous login reward is as follows: If you have not logged in on a certain day, the reward of that day is 0, otherwise the reward is the previous day's plus 1.

On the other hand, Pierre is very fond of the number N. He wants to get exactly N points reward with the least possible interruption of continuous login.

Input

There are multiple test cases. The first line of input is an integer T indicates the number of test cases. For each test case:

There is one integer N (1 <= N <= 123456789).

Output

For each test case, output the days of continuous login, separated by a space.

This problem is special judged so any correct answer will be accepted.

Sample Input
4
20
19
6
9
Sample Output
4 4
3 4 2
3
2 3
Hint

20 = (1 + 2 + 3 + 4) + (1 + 2 + 3 + 4)

19 = (1 + 2 + 3) + (1 + 2 + 3 + 4) + (1 + 2)

6 = (1 + 2 + 3)

9 = (1 + 2) + (1 + 2 + 3)

Some problem has a simple, fast and correct solution.


题目的意思是给出一个数n是的n分成若干的数的和,每个数是重1累加奥x的,保证数字个数最

找规律发现最多出现3项,分别对1项2项3项讨论,枚举加二分


#include <iostream>
#include<queue>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<set>
#include <cstring>
using namespace std;
#define LL long long
int a[100005];

int main()
{
    int T,n;
 a[0]=0;
   for(int i=1;i<100005;i++)
    a[i]=a[i-1]+i;
    scanf("%d",&T);
    while(T--)
    {
        int flag=0;
        scanf("%d",&n);
       for(int i=0;i<100000;i++)
       {
           if(a[i]==n){
               flag=1;
               printf("%d\n",i);
               break;
           }
           if(a[i]>n) break;
       }

        if(flag) continue;
       for(int i=0;a[i]<n;i++)
       {
           int x=n-a[i];
           int pos=lower_bound(a,a+100000,x)-a;
           if(a[pos]==x)
           {
               flag=1;
               printf("%d %d\n",i,pos);
               break;
           }
       }
       if(flag) continue;
       for(int i=0;a[i]<n;i++)
       {
           for(int j=0;a[j]<n-a[i];j++)
           {
              int x=n-a[i]-a[j];
           int pos=lower_bound(a,a+100000,x)-a;
           if(a[pos]==x)
           {
               flag=1;
               printf("%d %d %d\n",i,j,pos);
               break;
           }
           }
           if(flag) break;
       }

    }


    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值