HDU2976 Dropping tests

Dropping tests
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12187 Accepted: 4257

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

Source

————————————————————————————————

给出n和分数,可以去其中m个,求剩下的分子之和除以分母之和最大

思路:二分答案,验证去了m个后能否达到


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <string>
#include <vector>
using namespace std;
#define inf 0x3f3f3f3f
#define LL long long

int n,m;
struct node{
LL a,b;
}p[100005];
double k;

bool cmp(node a,node b)
{
    double x=a.a-(a.b*k);
    double y=b.a-(b.b*k);
    return x>y;
}

bool ok(double mid)
{
    k=mid;
    sort(p,p+n,cmp);
    LL x=0,y=0;
    for(int i=0;i<n-m;i++)
    {
        x+=p[i].a;
        y+=p[i].b;
    }
    double ans=x*1.0/y;
    if(ans>=mid)
        return 1;
    return 0;

}


int main()
{
    while(~scanf("%d%d",&n,&m)&&(m||n))
    {
        for(int i=0;i<n;i++)
            scanf("%lld",&p[i].a);
            for(int i=0;i<n;i++)
            scanf("%lld",&p[i].b);

    double l=0,r=1;
    while(r-l>1e-5)
    {
    double mid=(l+r)/2;
        if(ok(mid))
        {
            l=mid;
        }
        else
            r=mid;
    }
    l*=100;
    printf("%.0f\n",l);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值