ZOJ2417 Lowest Bit

Lowest Bit

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.


Input

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.


Output

For each A in the input, output a line containing only its lowest bit.


Sample Input

26
88
0


Sample Output

2
8



———————————————————————————————————

题目的意思是给出一个n,求出n化为2进制后从低位开始第一个1代表的数

思路:无

AC代码1:化成2进制

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <set>
#include <stack>
#include <map>
#include <functional>
#include <bitset>
#include <string>

using namespace std;

#define LL long long
#define INF 0x3f3f3f3f


int main()
{
    int n;
    int a[100];
    while(~scanf("%d",&n)&&n)
    {
        int len=0;
        while(n)
        {
            a[len++]=n%2;
            n/=2;
        }
        int ans=1;
        for(int i=0;i<len;i++)
        {
            if(!a[i]) ans*=2;
            else break;
        }
        printf("%d\n",ans);
    }
    return 0;
}



AC代码2:利用计算机补码快速算,树状数组原理

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <set>
#include <stack>
#include <map>
#include <functional>
#include <bitset>
#include <string>

using namespace std;

#define LL long long
#define INF 0x3f3f3f3f

int lowbit(int x)
{
return x&-x;
}

int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        printf("%d\n",lowbit(n));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值