POJ3111 K Best

K Best
Time Limit: 8000MS Memory Limit: 65536K
Total Submissions: 10261 Accepted: 2644
Case Time Limit: 2000MS Special Judge

Description

Demy has n jewels. Each of her jewels has some value vi and weight wi.

Since her husband John got broke after recent financial crises, Demy has decided to sell some jewels. She has decided that she would keep k best jewels for herself. She decided to keep such jewels that their specific value is as large as possible. That is, denote the specific value of some set of jewels S = {i1i2, …, ik} as

.

Demy would like to select such k jewels that their specific value is maximal possible. Help her to do so.

Input

The first line of the input file contains n — the number of jewels Demy got, and k — the number of jewels she would like to keep (1 ≤ k ≤ n ≤ 100 000).

The following n lines contain two integer numbers each — vi and wi (0 ≤ vi ≤ 106, 1 ≤ wi ≤ 106, both the sum of all vi and the sum of all wi do not exceed 107).

Output

Output k numbers — the numbers of jewels Demy must keep. If there are several solutions, output any one.

Sample Input

3 2
1 1
1 2
1 3

Sample Output

1 2

Source

Northeastern Europe 2005, Northern Subregion

[Submit]   [Go Back]   [Status]   [Discuss]


——————————————————————————————————

题目的的意思是给出n个分数取其中m个,要求分子之和与分母之和之比最大

思路:二分+验证

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <string>
#include <vector>
using namespace std;
#define inf 0x3f3f3f3f
#define LL long long

int n,m;
struct node
{
    int a,b,id;
} p[100005];
double k;

bool cmp(node a,node b)
{
    double x=a.a-(a.b*k);
    double y=b.a-(b.b*k);
    return x>y;
}

bool ok(double mid)
{
    k=mid;
    sort(p,p+n,cmp);
    LL x=0,y=0;
    for(int i=0; i<m; i++)
    {
        x+=p[i].a;
        y+=p[i].b;
    }
    double ans=x*1.0/y;
    if(ans>=mid)
        return 1;
    return 0;

}


int main()
{
    while(~scanf("%d%d",&n,&m)&&(m||n))
    {
        for(int i=0; i<n; i++)
            scanf("%d%d",&p[i].a,&p[i].b),p[i].id=i+1;
        double l=0,r=1e6;
        while(r-l>1e-5)
        {
            double mid=(l+r)/2;
            if(ok(mid))
                l=mid;
            else
                r=mid;
        }
        int q=0;
        for(int i=0; i<m; i++)
        {
            if(q++)
                printf(" ");
            printf("%d",p[i].id);
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值