HDU5826 physics

physics

                                                                          Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                                                                                                    Total Submission(s): 825    Accepted Submission(s): 457


Problem Description
There are n balls on a smooth horizontal straight track. The track can be considered to be a number line. The balls can be considered to be particles with the same mass.

At the beginning, ball i is at position Xi. It has an initial velocity of Vi and is moving in direction  Di.(Di1,1)
Given a constant C. At any moment, ball its acceleration Ai and velocity Vi have the same direction, and magically satisfy the equation that Ai * Vi = C.
As there are multiple balls, they may collide with each other during the moving. We suppose all collisions are perfectly elastic collisions.

There are multiple queries. Each query consists of two integers t and k. our task is to find out the k-small velocity of all the balls t seconds after the beginning.

* Perfectly elastic collision : A perfectly elastic collision is defined as one in which there is no loss of kinetic energy in the collision.
 

Input
The first line contains an integer T, denoting the number of testcases.

For each testcase, the first line contains two integers n <= 10^5 and C <= 10^9.
n lines follow. The i-th of them contains three integers Vi, Xi, Di. Vi denotes the initial velocity of ball i. Xi denotes the initial position of ball i. Di denotes the direction ball i moves in. 

The next line contains an integer q <= 10^5, denoting the number of queries.
q lines follow. Each line contains two integers t <= 10^9 and 1<=k<=n.
1<=Vi<=10^5,1<=Xi<=10^9
 

Output
For each query, print a single line containing the answer with accuracy of 3 decimal digits.
 

Sample Input
  
  
1 3 7 3 3 1 3 10 -1 2 7 1 3 2 3 1 2 3 3
 

Sample Output
  
  
6.083 4.796 7.141

————————————————————————————————————

题意:给出n个相同小球的初速度和初位置,初方向,v*a=c,碰撞为完全弹性碰撞,问t时刻的第k小的速度为多少

思路:碰撞为交换速度,所以不用管位置和方向。积分计算每个求时间即可 注意爆int

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int n,q,x,d,y;
double v[100009],c;

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%lf",&n,&c);
        for(int i=1;i<=n;i++)
            scanf("%lf%d%d",&v[i],&x,&d);
        sort(v+1,v+1+n);
        scanf("%d",&q);
        while(q--)
        {
            scanf("%d%d",&x,&y);
            double vv=v[y];
            printf("%.3lf\n",1.0*sqrt(2*c*x+vv*vv));
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值