HDU6195 cable cable cable

75 篇文章 0 订阅

cable cable cable

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 90    Accepted Submission(s): 79


Problem Description
Connecting the display screen and signal sources which produce different color signals by cables, then the display screen can show the color of the signal source.Notice that every signal source can only send signals to one display screen each time. 
Now you have  M  display screens and  K  different signal sources( KM2321 ). Select  K  display screens from  M  display screens, how many cables are needed at least so that **any**  K  display screens you select can show exactly  K  different colors.
 

Input
Multiple cases (no more than  100 ), for each test case:
there is one line contains two integers  M  and  K .
 

Output
Output the minimum number of cables  N .
 

Sample Input
      
      
3 2 20 15
 

Sample Output
      
      
4 90
Hint
As the picture is shown, when you select M1 and M2, M1 show the color of K1, and M2 show the color of K2. When you select M3 and M2, M2 show the color of K1 and M3 show the color of K2. When you select M1 and M3, M1 show the color of K1.
 

Source
 


——————————————————————————————————
题目的意思是给出m台显示器和k种颜色,要求每台显示器匹配一或多种颜色,
使得任意的选出k台都能颜色不相同
思路:找规律
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int main()
{
    LL k,m;
    while(~scanf("%lld%lld",&m,&k))
    {
        LL temp=m-k+1;
        printf("%lld\n",temp*k);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值