HDU3555 Bomb

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 19868    Accepted Submission(s): 7384


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

Author
fatboy_cw@WHU
 

Source
———————————————————————————————————

题目的意思是求小于等于n的包含49的数有几个

思路:数位dp,三维数组保存到len为止,结尾是i的,是否已经有49的数有几个,dfs维护

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 10000005
#define Mod 10001
using namespace std;
#define LL long long

LL dp[200][20][2];
int a[10];

LL dfs(int len,int pre,int sta,bool limit)
{
    if(len<0)
        return sta;
    if(dp[len][pre][sta]!=-1&&!limit)
        return dp[len][pre][sta];
    int up=limit?a[len]:9;
    LL ans=0;
    for(int i=0; i<=up; i++)
    {

        ans+=dfs(len-1,i,(pre==4&&i==9)||sta,limit&&i==up);
    }
    return limit?ans:dp[len][pre][sta]=ans;
}

LL solve(LL x)
{
    memset(dp,-1,sizeof dp);
    int cnt=0;
    while(x>0)
    {
        a[cnt++]=x%10;
        x/=10;
    }
    return dfs(cnt-1,-1,0,1);
}

int main()
{
    int T;
    LL n;
    for(scanf("%d",&T); T--;)
    {
        scanf("%lld",&n);
        printf("%lld\n",solve(n));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值