[数位DP] D - Bomb HDU - 3555

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 22823    Accepted Submission(s): 8590


 

Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

 

 

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

 

 

Output

For each test case, output an integer indicating the final points of the power.

 

 

Sample Input

 

3

1

50

500

 

 

Sample Output

 

0

1

15

Hint

From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.

 

 

Author

fatboy_cw@WHU

 

 

Source

2010 ACM-ICPC Multi-University Training Contest(12)——Host by WHU

 

 

#include <bits/stdc++.h>

using namespace std;

int ch[100];
long long dp[100][2][2];

long long dfs(int pos, bool in, bool pre, bool limit)
{
	if (pos == 0)
		return in;
	
	if (!limit && dp[pos][in][pre])
		return dp[pos][in][pre];

	long long res = 0;
	int up = limit ? ch[pos] : 9;
	for (int i = 0; i <= up; i++)
	{
		bool t = (limit && i == up);
		
		if (pre && i == 9)  /// 新增符合条件情况
			res += dfs(pos - 1, 1, 0, t);
		else  /// 原情况不变
			res += dfs(pos - 1, in, i == 4, t);
	}
	if (!limit)
		dp[pos][in][pre] = res;
	
	return res;
}

long long solve(long long n)
{
	int cnt = 0;
	while (n > 0)
	{
		ch[++cnt] = n % 10;
		n /= 10;
	}
	return dfs(cnt, 0, 0, 1);
	/// 当前位, 是否已包含49, 前一位是否为4, 是否有上限 DP数组同
}

int main()
{
	#ifndef ONLINE_JUDGE
		freopen("D:\\in.txt", "r", stdin);
	#endif // ONLINE_JUDGE
	
	int T;
	scanf("%d", &T);
	while (T--)
	{
		long long n;
		scanf("%lld",&n);
		printf("%lld\n", solve(n));
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值