HDU 5289 Assignment

Assignment


Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)



Problem Description
Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.
 

Input
In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.
 

Output
For each test,output the number of groups.
 

Sample Input
  
  
2 4 2 3 1 2 4 10 5 0 3 4 5 2 1 6 7 8 9
 

Sample Output
  
  
5 28
Hint
First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3]

 
/*
RMQ-ST算法
求所有区间最大值与最小值差不超过K的区间个数
两个dp记录区间最大值最小值
遍历区间起点i,二分查找满足条件的区间终点j
ans+=(j-i+1);
*/
#include <set>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <cstdio>
#include <bitset>
#include <string>
#include <vector>
#include <iomanip>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <functional>
#define maxn 100010
#define inf 0x7fffffff
using namespace std;
int dp[21][maxn * 2];
int dp2[21][maxn * 2];
int a[maxn];
long long ans;
int n, kk;
void ST(int num)
{
        for (int i = 1; i <= num; i++)
        {
                dp[0][i] = a[i];
                dp2[0][i] = a[i];
        }
        for (int i = 1; i <= log2(num); i++)
                for (int j = 1; j <= num; j++)
                        if (j + (1 << i) - 1 <= num)
                        {
                                int a = dp[i - 1][j], b = dp[i - 1][j + (1 << i >> 1)];
                                if (a < b)
                                {
                                        dp[i][j] = a;
                                }
                                else
                                {
                                        dp[i][j] = b;
                                }
                                int a2 = dp2[i - 1][j], b2 = dp2[i - 1][j + (1 << i >> 1)];
                                if (a2 < b2)
                                {
                                        dp2[i][j] = b2;
                                }
                                else
                                {
                                        dp2[i][j] = a2;
                                }

                        }
}
int RMQ(int x, int y)
{
        int k = (int) log2(y - x + 1.0);
        int a = dp[k][x], b = dp[k][y - (1 << k) + 1];
        if (a > b)
        {
                swap(a, b);
        }
        int k1 = (int) log2(y - x + 1.0);
        int a1 = dp2[k1][x], b1 = dp2[k1][y - (1 << k1) + 1];
        if (a1 < b1)
        {
                swap(a1, b1);
        }
        return a1 - a;
}
int main()
{
        int T;
        scanf("%d", &T);
        while (T--)
        {

                scanf("%d %d", &n, &kk);
                for (int i = 1; i <= n; i++)
                {
                        scanf("%d", &a[i]);
                }
                ST(n);
                ans = 0;
                for (int i = 1; i <= n; i++)
                {
                        int left = i, right = n, mid;
                        while (left <= right)
                        {
                                mid = (left + right) / 2;
                                if (RMQ(i, mid) < kk)
                                {
                                        left = mid + 1;
                                }
                                else
                                {
                                        right = mid - 1;
                                }
                        }
                        ans += ((left + right) / 2 - i + 1);
                }
                printf("%I64d\n", ans);
        }
        return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值