HDU 5384 Danganronpa

Danganronpa


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)



Problem Description
Danganronpa is a video game franchise created and developed by Spike Chunsoft, the series' name is compounded from the Japanese words for "bullet" (dangan) and "refutation" (ronpa).

Now, Stilwell is playing this game. There are  n  verbal evidences, and Stilwell has  m  "bullets". Stilwell will use these bullets to shoot every verbal evidence.

Verbal evidences will be described as some strings  Ai , and bullets are some strings  Bj . The damage to verbal evidence  Ai  from the bullet  Bj  is  f(Ai,Bj) .
f(A,B)=i=1|A||B|+1[ A[i...i+|B|1]=B ]
In other words,  f(A,B)  is equal to the times that string  B  appears as a substring in string  A .
For example:  f(ababa,ab)=2 f(ccccc,cc)=4

Stilwell wants to calculate the total damage of each verbal evidence  Ai  after shooting all  m  bullets  Bj , in other words is  mj=1f(Ai,Bj) .
 

Input
The first line of the input contains a single number  T , the number of test cases.
For each test case, the first line contains two integers  n m .
Next  n  lines, each line contains a string  Ai , describing a verbal evidence.
Next  m  lines, each line contains a string  Bj , describing a bullet.

T10
For each test case,  n,m105 1|Ai|,|Bj|104 |Ai|105 |Bj|105
For all test case,  |Ai|6105 |Bj|6105 Ai  and  Bj  consist of only lowercase English letters
 

Output
For each test case, output  n  lines, each line contains a integer describing the total damage of  Ai  from all  m  bullets,  mj=1f(Ai,Bj) .
 

Sample Input
  
  
1 5 6 orz sto kirigiri danganronpa ooooo o kyouko dangan ronpa ooooo ooooo
 

Sample Output
  
  
1 1 0 3 7

 AC自动机,学了学,比用字典树快了300毫秒
/*
AC自动机-多串为单串子串的数目和
多串建立字典树
字典树上BFS建立传递指针
更新字典树val数组值
查询字符串
求出字符串路径上所有节点的val和
*/
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <set>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <cstdio>
#include <bitset>
#include <string>
#include <vector>
#include <iomanip>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <functional>
#define maxn 100005
using namespace std;
typedef long long LL;
const int SIGMA_SIZE = 26;
const int MAXN = 100010;
const int MAXNODE = 600010;
const LL MOD = 258280327;
int T, N, M;
LL ans;
string str1[MAXN], str2[MAXN];
struct AC
{
        int ch[MAXNODE][SIGMA_SIZE], sz;
        int f[MAXNODE]; //储存某一节点指向的节点的编号
        LL val[MAXNODE];
        void init()
        {
                memset(ch[0], 0, sizeof(ch[0]));
                val[0] = 0;
                sz = 1;
        }
        int idx(char c)
        {
                return c - 'a';
        }
        void insert_s(string s)
        {
                int u = 0, len = s.size();
                for (int i = 0; i < len; i++)
                {
                        int c = idx(s[i]);
                        if (!ch[u][c])
                        {
                                memset(ch[sz], 0, sizeof(ch[sz]));
                                val[sz] = 0;
                                ch[u][c] = sz++;
                        }
                        u = ch[u][c];
                }
                val[u]++;
        }
        void get_fail()
        {
                queue<int> q;
                f[0] = 0;
                for (int c = 0; c < SIGMA_SIZE; c++)
                {
                        int u = ch[0][c];
                        if (u)
                        {
                                f[u] = 0;
                                q.push(u);
                        }
                }
                while (!q.empty())
                {
                        int r = q.front();
                        q.pop();
                        for (int c = 0; c < SIGMA_SIZE; c++)
                        {
                                int u = ch[r][c];
                                if (!u)
                                {
                                        ch[r][c] = ch[f[r]][c];
                                        continue;
                                }
                                q.push(u);
                                //u 指向的编号为父节点r指向的编号的下一个c的编号
                                f[u] = ch[f[r]][c];
                                val[u] += val[f[u]];
                        }
                }
        }
        void find_s(string T)
        {
                int j = 0;
                int len = T.size();
                for (int i = 0; i < len; i++)
                {
                        int c = idx(T[i]);
                        j = ch[j][c];
                        ans += val[j];
                }
        }
} ac;
int main()
{
        scanf("%d", &T);
        while (T--)
        {
                scanf("%d%d", &N, &M);
                for (int i = 1; i <= N; i++)
                {
                        cin >> str1[i];
                }
                for (int i = 1; i <= M; i++)
                {
                        cin >> str2[i];
                }
                ac.init();
                for (int i = 1; i <= M; i++)
                {
                        ac.insert_s(str2[i]);
                }
                ac.get_fail();
                for (int i = 1; i <= N; i++)
                {
                        ans = 0;
                        ac.find_s(str1[i]);
                        printf("%I64d\n", ans);
                }
        }
        return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值