HDU 1031 Design T-Shirt

Design T-Shirt

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8622    Accepted Submission(s): 4115


Problem Description
Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.
 

Input
The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.
 

Output
For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.
 

Sample Input
  
  
3 6 4 2 2.5 5 1 3 4 5 1 3.5 2 2 2 1 1 1 1 1 10 3 3 2 1 2 3 2 3 1 3 1 2
 

Sample Output
  
  
6 5 3 1 2 1
 

Author
CHEN, Yue
 

Source

这道题目大概的意思就是给出N个人对M件衣服的评价,从中选出K件评价最高的衣服,这K件按序列号从大到小排序输出,用结构体记录衣服的编号和三个人对衣服评价的总和,之后用sort对评价分数排序,找出从大到小的K件衣服,然后这K件衣服再对序列号排序,输出序列号从大到小即可。代码如下:

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
struct FF{
	int id;
	double nun;
};
bool cmp1(FF ff,FF fff){
	return ff.id>fff.id;
} 
bool cmp2(FF ff,FF fff){
	return ff.nun>fff.nun;
}
int main(){
	int n,m,k;
	while(scanf("%d%d%d",&n,&m,&k)!=EOF){
		double a;
		 FF *ff = new FF[m+1];
		 for(int i=0;i<=m;i++)
		 {
		 	ff[i].id=i+1;ff[i].nun=0;
		 }
		 for(int i=0;i<n;i++){
		 	for(int j=0;j<m;j++){
		 		scanf("%lf",&a);
		 		ff[j].nun+=a;
			 }
		 }
		 sort(ff,ff+m,cmp2);
		 sort(ff,ff+k,cmp1);
		 for(int i=0;i<k-1;i++){
		 	printf("%d ",ff[i].id);
		 }
		 printf("%d\n",ff[k-1].id);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值