浙大数据结构习题笔记:04-树6 Complete Binary Search Tree (30分)

04-树6 Complete Binary Search Tree (30分)

题目

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

分析

其实觉得这道题和03-树2 List Leaves好像,都是采用递归的方式,都是先确定根,最后输出都是层次遍历的形式,这道题有一些数学推导和之前不太一样。

具体代码实现

#include<iostream>
#include<algorithm>
#include<cmath>
#define MAXSIZE 2005
using namespace std;

int A[MAXSIZE];
int T[MAXSIZE];

int getLeft(int n)
{
    int h = 0;
    int temp = n+1;
    while(temp != 1){
        temp /= 2;
        h++;    //测出左树高
    }
    int x = n - pow(2,h) +1;    //x代表和最后一行的节点数
    x = x<pow(2,h-1)?x:pow(2,h-1);  //x最多只能是2^(n-1)
    //如果最后一行有根的右树部分,x的值肯定大,所以要有这一步
    int L = pow(2,h-1) + x -1;  //左树总值
    return L;
}

void solve(int left,int right,int root)
{
    int n = right - left + 1;
    if(n == 0)
        return;
    int L = getLeft(n); //算出根的左树的节点数
    T[root] = A[left + L];  //每次记录根的位置,一步步来就可
    int LRoot = root * 2 +1;    //数学推导
    int RRoot = LRoot + 1;  //右子树根一定在左子树根的下一位
    solve(left,left+L-1,LRoot);
    solve(left+L+1,right,RRoot);
}

int main()
{
    int n;
    cin>>n;
    for(int i=0;i<n;i++){
        cin>>A[i];
    }
    sort(A,A+n);    //内嵌函数,排序
    solve(0,n-1,0);
    for(int j=0;j<n;j++){
        if(j!=0){
            cout<<" ";
        }
        cout<<T[j];
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值