1044. 火星数字(20)-浙大PAT乙级真题java实现

个人博客:打开链接

1044. 火星数字(20)
火星人是以13进制计数的:地球人的0被火星人称为tret。地球人数字1到12的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。火星人将进位以后的12个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。例如地球人的数字“29”翻译成火星文就是“hel mar”;而火星文“elo nov”对应地球数字“115”。为了方便交流,请你编写程序实现地球和火星数字之间的互译。
输入格式:
输入第一行给出一个正整数N(<100),随后N行,每行给出一个[0, 169)区间内的数字 —— 或者是地球文,或者是火星文。
输出格式:
对应输入的每一行,在一行中输出翻译后的另一种语言的数字。
输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115
13



import java.io.BufferedReader;
import java.io.InputStreamReader;

public class Main {
    static String[] basic = { "tret", "jan", "feb", "mar", "apr", "may", "jun",
            "jly", "aug", "sep", "oct", "nov", "dec" };
    static String[] high = { "tam", "hel", "maa", "huh", "tou", "kes", "hei",
            "elo", "syy", "lok", "mer", "jou" };

    public static void toEarthLanguage(String mar) {
        String[] mars = mar.split(" ");
        if (mars.length == 1) {
            for (int i = 0; i < basic.length; i++) {
                if (mars[0].equals(basic[i]))
                    System.out.println(i);
            }
            for (int i = 0; i < high.length; i++) {
                if (mars[0].equals(high[i]))
                    System.out.println((i + 1) * 13);
            }
        } else {
            int total = 0;

            for (int i = 0; i < high.length; i++) {
                if (mars[0].equals(high[i]))
                    total = (i + 1) * 13;
            }
            for (int i = 0; i < basic.length; i++) {
                if (mars[1].equals(basic[i]))
                    total = total + i;
            }
            System.out.println(total);
        }
    }

    public static void toMarsLanguage(int earth) {
        if (earth < 13) {
            System.out.println(basic[earth]);
        } else if (earth % 13 == 0) {
            System.out.println(high[earth / 13 - 1]);
        } else
            System.out.println(high[earth / 13 - 1] + " " + basic[earth % 13]);

    }

    public static void main(String[] args) throws Exception {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        int n = Integer.parseInt(br.readLine());

        for (int j = 0; j < n; j++) {
            String num = br.readLine();
            if (num.matches("[0-9]{1,}")) {
                toMarsLanguage(Integer.parseInt(num));
            } else {
                toEarthLanguage(num);
            }
        }
    }

}

这里写图片描述

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

勤奋的凯尔森同学

你的鼓励将是我创作的最大动力!

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值