H-火车进站问题(卡特兰数列)

本文探讨了一种列车调度问题,即当所有列车以递增顺序进入车站时,可以有多少种不同的出站顺序。通过使用卡特兰数这一数学概念,我们能够有效地解决这个问题,并提供了一个Java实现示例,利用了BigInteger类来处理可能非常大的结果。
摘要由CSDN通过智能技术生成
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.

 

Input

The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.

Output

For each test case, you should output how many ways that all the trains can get out of the railway.

Sample Input

1
2
3
10

Sample Output

1
2
5
16796


        
  

Hint

The result will be very large, so you may not process it by 32-bit integers.

        
 
简单的卡特兰数问题。
卡特兰数介绍:
http://www.acmerblog.com/catalan-5196.html
由于Java里面有一个大数类,所以我就直接用了,有空我会把大数运算的处理补上
import java.math.BigInteger;
import java.util.*;
public class Main {
    static Scanner in = new Scanner(System.in);
	public static void main(String[] args) {
		while(in.hasNext()){
       int n=in.nextInt();
       BigInteger[] num=new BigInteger[105];
       num[0]=num[1]=new BigInteger("1");
       BigInteger a,b;
       for (int i = 2; i <=n; i++) {
		    a=new BigInteger(Integer.toString(4*i-2));
		    b=new BigInteger(Integer.toString(i+1));
		    num[i]=num[i-1].multiply(a).divide(b);
	    }
      System.out.println(num[n]);
	  }
	}
}

主要是理解卡兰特数列一起应用问题:先构造数列,直接用即可,同斐波那契数列的应用,关键是抽象出数学模型

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值