HDOJ 1381 Crazy Search

Crazy Search

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2357    Accepted Submission(s): 882


Problem Description
Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.

Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa", "aab", "aba", "bab", "bac". Therefore, the answer should be 5. 
 

Input
The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.
 

Output
The program should output just an integer corresponding to the number of different substrings of size N found in the given text.
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

 

Sample Input
  
  
1 3 4 daababac
 

Sample Output

5

题目大意:

N是子串的长度,NC是不一样的字符数量。问你字符串里有多少个不同的子串。

解题思路:

就是将每一个子串表示成一个整数,即是Hash的思想。我的思路是将每个子串用NC进制的方式表示。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

int T,N,NC;
char S[16000005];
int ans,len,K,sum;
int book[130];  //记录不同字符所代表的整数
bool Hash[16000005];//标记每个子串是否出现过

int main()
{
	while(cin>>T)
	{
		while(T--)
		{
			memset(book,-1,sizeof(book));
			memset(Hash,false,sizeof(Hash));
			K=0;
			getchar();
			cin>>N>>NC>>S;
			
			len = strlen(S);
			for(int i=0;S[i]!='\0';i++)
			{
				if(book[S[i] - 'A'] == -1)
				{
					book[S[i] - 'A'] = K++;
					if(K==NC) break;
				}
			}
			ans = len-N+1;
	
			sum=0;
			for(int i=0;i<N;i++)
			sum = sum*NC + book[S[i] - 'A'];//先算出第一个子串所代表的值

			Hash[sum] = true;
			
			for(int i=N;i<len;i++)
			{
<pre code_snippet_id="1579932" snippet_file_name="blog_20160216_2_5935846" name="code" class="cpp" style="font-size: 14px;"><span style="white-space:pre">		</span>//下一个子串所代表的值与上一个子串有一个关系,应用这个关系可优化程序
				sum = (sum-(book[S[i-N]-'A'])*(int)pow((double)NC,N-1))*NC+book[S[i] - 'A'];
				if(Hash[sum])
				--ans;
				else
				Hash[sum] = true;
			}
			cout<<ans<<endl;
		}
	}
	return 0;
}

 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值