Matrix Chain Multiplication



Problem Description
Matrix multiplication problem is a typical example of dynamical programming.

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.
For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.
There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.
 

Input
Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.
The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix = "A" | "B" | "C" | ... | "X" | "Y" | "Z"
 

Output
For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.
 

Sample Input
  
  
9 A 50 10 B 10 20 C 20 5 D 30 35 E 35 15 F 15 5 G 5 10 H 10 20 I 20 25 A B C (AA) (AB) (AC) (A(BC)) ((AB)C) (((((DE)F)G)H)I) (D(E(F(G(HI))))) ((D(EF))((GH)I))
 

Sample Output
  
  
0 0 0 error 10000 error 3500 15000 40500 47500 15125
 

Source



分析:
         借看刘汝佳老师的那本算法书上的对该题的分析如下:      本体的关键就是解析表达式。本体的表达式比较简单,可以用一个栈来完成,遇到字母时入栈,遇到右括号时出栈并计算,然后结果入栈。因为输入保证核发,括号无需入栈。
        例:A是50*10   B是10*20,  C是20*5的,则(A(BC))的乘法次数为10*20*5(BC的乘法次数)+50*10*5(A(BC)的乘法次数)=3500.。
      另外知识点:
        函数名称                                                                                      函数功能
         isalpha                                                                             检查元素是否为字母
         isdigt                                                                                检查元素是否为梳子(0~9)
         islower                                                                             检查元素是否为小写字母
         isalnum                                                                            检查元素是否为字母或数字
#include<iostream>
#include<cstdio>
#include<cstring>
#include<stack>
#include<algorithm>
using namespace std;

struct Matrix{//定义矩阵类型的结构体 
  int a,b;
  Matrix(int a=0,int b=0):a(a),b(b){
  }
}m[26];//结构体数组 

stack<Matrix>s;//运用到栈的知识; 


int main()
{
	int n;
	cin>>n;
	for(int i=0;i<n;i++){
		string name;
		cin>>name;
		int  k=name[0]-'A';//将字母转换为数字的形式进行保存; 
		cin>>m[k].a>>m[k].b;
	}
	string expr;//定义字符串进行输入; 
	while(cin>>expr){
		int len=expr.length();//计算长度 
		bool error = false ;//标记 
		int ans = 0;//计算这个乘法的和; 
		for(int i=0;i<len;i++)
		{
			if(isalpha(expr[i])) //这是一个函数,其作用:检测该元素是不是为字母的形式  
			  s.push(m[expr[i]-'A']);//入栈; 
			else if(expr[i]==')'){
				Matrix m2 =s.top(); s.pop();       
				Matrix m1 =s.top(); s.pop();
				if(m1.b!=m2.a)    {    //判断是否可以进行合法的乘法运算   否则就进行标记 
					error = true ;
					break;
				}
				ans+=m1.a*m1.b*m2.b;
				s.push(Matrix(m1.a,m2.b));
			}
		}
		if(error)    printf("error\n");  
		else         printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值