hdu 1222 Wolf and Rabbit(扩展欧几里德)

There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 
Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 
Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 
Sample Input
  
  
2 1 2 2 2
 
Sample Output
  
  
NO YES
 
思路:如果狼能够把所有的洞口能把所有的洞都探一次,那么,兔子肯定是不安全的。否则,兔子就有可能是安全的。
最开始的时候差不点去开数组然后模拟过程了,但是一看到所给数的范围,就打消这个念头了。
这道题运用了扩展欧几里德算法的知识。我们假设当前洞口的位置是s,洞口的总数如题意所给是n,狼每隔m个洞就查找一次洞,那么,当符合这个等式:
(s + a*n) = b*m   的时候,兔子就被发现了。这当中a,b是两个未知的整数。我们把这个式子转化一下:
s = b*m - a*n
所以,就转变成了这样一个问题:是否存在a,b两个整数使得整数成立,那么什么时候一定存在呢?当s = gcd(m, n)的时候一定成立(扩展欧几里德的内容)。而当m,n互素的时候,狼肯定能把所有的洞口都查找一遍(这是客观规律,不必过于纠结)。
所以当gcd(m, n)==1的时候,兔子肯定是不安全的。否则,兔子是有可能安全的。
代码:
#include<iostream>
using namespace std;
int gcd(int a,int b)
{
    if(0==a%b)
    {
        return b;
    }
    else
    {
        return gcd(b,a%b);
    }
}

int main()
{
    int testNum;
    int m,n;

    cin>>testNum;
    while(testNum--)
    {
        cin>>m>>n;
        if(1==gcd(m,n))
        {
            cout<<"NO"<<endl;
        }
        else
        {
            cout<<"YES"<<endl;
        }
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值