杭电 1222 Wolf and Rabbit(题解+代码)

题目传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1222
题目:

Wolf and Rabbit
Problem Description

There is a hill with n holes around. The holes are signed from 0 to n-1.
在这里插入图片描述
A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).

Output

For each input m n, if safe holes exist, you should output “YES”, else output “NO” in a single line.
Sample Input

2
1 2
2 2

Sample Output

NO
YES

题意:一只狼逆时针绕着一个小山丘的地洞找小兔子,假设第一个地洞为0,则最后一个地洞为n-1。现在狼是每碰到第m倍数个地洞,才会进去找兔子,求兔子有没有地方可以藏。
题解:由于地洞的数量以及狼所找的地洞间隔数都是固定的。那么可以通过判断地洞的数量和寻找间隔数的最小公因数是否为1,如果为1的话,则兔子无处可藏,否则的话狼找不到兔子
其实看懂题意了之后,这就是道gcd的水题
代码如下:

#include<stdio.h>
int gcd(int a,int b) {
    return a%b==0?b:gcd(b,a%b);
}
int main() {
    int n,a,b;
    scanf("%d",&n);
    for(int i=1;i<=n;i++) {
        scanf("%d%d",&a,&b);
        if(gcd(a,b)!=1) printf("YES\n"); 
        else printf("NO\n");
    } 
    return 0;
}

ac图片

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值