【bzoj1677】[Usaco2005 Jan]Sumsets 求和

1677: [Usaco2005 Jan]Sumsets 求和

Time Limit: 5 Sec  Memory Limit: 64 MB
Submit: 970  Solved: 562[Submit][Status][Discuss]

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 1) 1+1+1+1+1+1+1 2) 1+1+1+1+1+2 3) 1+1+1+2+2 4) 1+1+1+4 5) 1+2+2+2 6) 1+2+4 Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

给出一个N(1N10^6),使用一些2的若干次幂的数相加来求之.问有多少种方法

Input

   一个整数N.

Output

方法数.这个数可能很大,请输出其在十进制下的最后9位.

Sample Input

7

Sample Output

6

有以下六种方式
1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

HINT

Source

[Submit][Status][Discuss]
心态崩了。。
水题交了五六次还不过。。
检查一下发现几个地方零多打了。。。
我真菜。。
这题就是简单的背包啊。。然后物品的重量就是那个二的若干次方
预处理一下就好
代码:
#include<iostream>
#include<cstdio>
using namespace std;

const int maxn = 1000010;
int n,a[100],f[maxn];

int main()
{
	scanf("%d",&n);
	f[0] = 1;
	int len = 0;
	for (int i = 1; i <= n; i *= 2)
		a[++len] = i;	
	for (int i = 1; i <= len; i++)
		for (int j = a[i]; j <= n; j++)
			f[j] = (f[j] + f[j-a[i]]) % 1000000000;
	printf("%d",f[n]);
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值