Large Division(大数取余)

**Link:**https://vjudge.net/contest/172540#problem/L

题目:

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.
Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print ‘divisible’ if a is divisible by b. Otherwise print ‘not divisible’.

Sample Input

6
101 101
0 67
-101 101
7678123668327637674887634 101
11010000000000000000 256
-202202202202000202202202 -101

Sample Output

Case 1: divisible
Case 2: divisible
Case 3: divisible
Case 4: not divisible
Case 5: divisible
Case 6: divisible

思路:

同余定理:
	
	根据同余定理可得出:(a+b)%c=((a%c)+(b%c))%c

a%c举例:

对于一个大数求其%N 的值,例如求1234 可以写成 11000+2100+310+4 =((110)+2)*10+3)10+4 所以 1234%N=(((110)%N+2)*10%N+3)*10%N+4%N

程序关键点:

设一整型数据ans存储结果 ans=0;
ans=(ans*10+a[i])%N (a[i] 代表数据每个位上的数据)

Code:

#include<stdio.h>
#include<string.h>
int main() 
{
	int T,b,l;
	char s[220];
	int i,j;
	long long sum;
	scanf("%d",&T);
	for(i=1; i<=T; i++) {
		scanf("%s %d",s,&b);
		l=strlen(s);
		for(j=sum=0; j<l; j++) {
			if(s[j]!='-') {
				sum=(sum*10+s[j]-'0')%b;
			}
		}
		if(!sum)
			printf("Case %d: divisible\n",i);
		else
			printf("Case %d: not divisible\n",i);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值