大数求模

Large Division(大数求模)

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.
给定两个整数a和b,你应该检查a是否能被b整除。我们知道整数a可以被整数b整除,如果且仅当存在整数c时,a = b * c。


Input
Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.
输入从一个整数T(≤525),表示测试用例的数量。

每个案例始于一行包含两个整数(-10200≤≤10200)和b(| | b > 0,b适用于32位有符号整型)。数字将不包含前导零。

Output
For each case, print the case number first. Then print ‘divisible’ if a is divisible by b. Otherwise print ‘not divisible’.
对于每个案例,首先打印案例编号。如果a被b整除,则打印“divisible”,否则打印“not divisible”。


思路:对于大数运算我们要明白int,long long是不足以存储数据的。这时候我们就要想到用字符串来表示。


Sample Input
6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101


Sample Output
Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible


#include<stdio.h>
#include<string.h>
#include<math.h>
#include<cmath>
#include<cstdio>
#include<iostream>
#include<cstring>
#include<string>
using namespace std;
typedef long long ll;
char a[220];
int b;          //大数求模a[n],n表示10的几次方 
int main()
{   ll n,sum,t=0,i;
    scanf("%lld",&n);
    while(n--)
    {   sum=0;
        t++;
        scanf("%s%lld",a,&b);
        b=abs(b);
        for(i=(a[0]=='-');i<strlen(a);i++)
        {
            sum*=10;
            sum+=a[i]-'0';
            sum%=b;
        }
        printf("Case %lld: %s\n",t,sum?"not divisible":"divisible");
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值