17年浙江省省赛C-What Kind of Friends Are You?

6 篇文章 0 订阅
6 篇文章 0 订阅

这道算是一道比较麻烦的水题。麻烦是针对我来说的,因为涉及到 map 的操作和长长的题干。
本来想节选一下,但是英文的概括能力太差= =

大意:

多组数据。
Kaban 有 n 个朋友,现在给出 c 个名字,他们中有 n 个是 Kaban 的朋友。Kaban 问 q 个问题来确定她的朋友。 回答 yes(1)的是她的朋友,回答no(0)的不是。现在知道 每个问题得到的回应和每个真正的朋友的回答情况,问能否确定她的朋友。

Time Limit:1000ms Memory Limit:65535 KB
Description
Japari Park is a large zoo home to extant species, endangered species, extinct species, cryptids and some legendary creatures. Due to a mysterious substance known as Sandstar, all the animals have become anthropomorphized into girls known as Friends.

Kaban is a young girl who finds herself in Japari Park with no memory of who she was or where she came from. Shy yet resourceful, she travels through Japari Park along with Serval to find out her identity while encountering more Friends along the way, and eventually discovers that she is a human.

However, Kaban soon finds that it’s also important to identify other Friends. Her friend, Serval, enlightens Kaban that she can use some questions whose expected answers are either “yes” or “no” to identitfy a kind of Friends.

To be more specific, there are n Friends need to be identified. Kaban will ask each of them q same questions and collect their answers. For each question, she also gets a full list of animals’ names that will give a “yes” answer to that question (and those animals who are not in the list will give a “no” answer to that question), so it’s possible to determine the name of a Friends by combining the answers and the lists together.

But the work is too heavy for Kaban. Can you help her to finish it?

Input

There are multiple test cases. The first line of the input is an integer T (1 ≤ T ≤ 100), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains two integers n (1 ≤ n ≤ 100) and q (1 ≤ q ≤ 21), indicating the number of Friends need to be identified and the number of questions.

The next line contains an integer c (1 ≤ c ≤ 200) followed by c strings p1, p2, … , pc (1 ≤ |pi| ≤ 20), indicating all known names of Friends.

For the next q lines, the i-th line contains an integer mi (0 ≤ mi ≤ c) followed by mi strings si, 1, si, 2, … , si, mi (1 ≤ |si, j| ≤ 20), indicating the number of Friends and their names, who will give a “yes” answer to the i-th question. It’s guaranteed that all the names appear in the known names of Friends.

For the following n lines, the i-th line contains q integers ai, 1, ai, 2, … , ai, q (0 ≤ ai, j ≤ 1), indicating the answer (0 means “no”, and 1 means “yes”) to the j-th question given by the i-th Friends need to be identified.

It’s guaranteed that all the names in the input consist of only uppercase and lowercase English letters.

Output

For each test case output n lines. If Kaban can determine the name of the i-th Friends need to be identified, print the name on the i-th line. Otherwise, print “Let’s go to the library!!” (without quotes) on the i-th line instead.

Sample Input

2
3 4
5 Serval Raccoon Fennec Alpaca Moose
4 Serval Raccoon Alpaca Moose
1 Serval
1 Fennec
1 Serval
1 1 0 1
0 0 0 0
1 0 0 0
5 5
11 A B C D E F G H I J K
3 A B K
4 A B D E
5 A B K D E
10 A B K D E F G H I J
4 B D E K
0 0 1 1 1
1 0 1 0 1
1 1 1 1 1
0 0 1 0 1
1 0 1 1 1
Sample Output

Serval
Let’s go to the library!!
Let’s go to the library!!
Let’s go to the library!!
Let’s go to the library!!
B
Let’s go to the library!!
K
Hint

The explanation for the first sample test case is given as follows:

As Serval is the only known animal who gives a “yes” answer to the 1st, 2nd and 4th question, and gives a “no” answer to the 3rd question, we output “Serval” (without quotes) on the first line.

As no animal is known to give a “no” answer to all the questions, we output “Let’s go to the library!!” (without quotes) on the second line.

Both Alpaca and Moose give a “yes” answer to the 1st question, and a “no” answer to the 2nd, 3rd and 4th question. So we can’t determine the name of the third Friends need to be identified, and output “Let’s go to the library!!” (without quotes) on the third line.

分析及反思:
用 map< string , string > 存每个 name 的答题情况 如 mm[“Serval”] = “1101”。再用迭代器遍历,判断是否存在为真实朋友

据说别人 map T 了,反正我的是 AC 了,因为数据量不大,按理说勉强能 AC 。如果还是 T 的话,就把 string 用哈希技术处理。

思路全清晰,但卡了一段时间,原因竟然是:…

  1. 迭代器it 访问 first 应该是 it->first,同理 it->second
    。或者( * it).first 而绝不是 * it.first (错误)
    点运算符的优先级高于 * 。
  2. 再也不要用 n nn 这种命名规则了!错了都找不出来。
  3. map 没有直接对 value 的查找操作,用 for 遍历一遍,map本来就慢,有些题目不好用。
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
#define mem(s,t) memset(s,t,sizeof(s))
#define D(v) cout<<#v<<" "<<v<<endl
#define inf 0x3f3f3f3f

map<string,string> mm;
map<string,string>::iterator it,it2;
int main(){
    int T;cin>>T;
    while(T--){
        mm.clear();
        int n,q;
        cin>>n>>q;
        int c;cin>>c;
        for(int i=0;i<c;i++){
            string s;
            cin>>s;
            mm[s]="";
        }
        for(int i=0;i<q;i++){
            int t;cin>>t;
            for(int j=0;j<t;j++){
                string ss;cin>>ss;
                mm[ss]=mm[ss]+"1";
            }
            for(map<string,string>::iterator it=mm.begin();it!=mm.end();it++){
                if(((*it).second).size()<i+1){
                    it->second=it->second+"0";
                }
            }
        }
        for(int i=0;i<n;i++){
            string ss="";
            for(int j=0;j<q;j++){
                string temp;
                cin>>temp;
                ss=ss+temp;
            }
            int nn=0;
            for(it2 = mm.begin();it2!=mm.end();it2++){
                if(it2->second==ss){
                    nn++;
                }
            }
            for(it = mm.begin();it!=mm.end();it++){
                if(it->second==ss){
                    break;
                }
            }
            if(it==mm.end()){
                puts("Let's go to the library!!");
            }else if(nn!=1){
                puts("Let's go to the library!!");
            }else{
                cout<<it->first<<endl;
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值