甲级PAT 1039 Course List for Student (25 分)(map、散列、set)

1039 Course List for Student (25 分)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​ (≤200) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

题目要求:

浙大N(<=40000)名学生在K(<=2500)门课程中选课。给出K门课程每门的课程号、所选人数以及所选学生的姓名,按查询学生的姓名序列给出每位学生选的课的数量以及选了哪些课(课程号按着递增顺序排序)。学生的姓名由3个大写字母和一个数字组成。K的下标从1开始。

解题思路:

用一个set集合存储学生选的课程id,用map将学生姓名和所选课程id的set集合映射。然后根据学生姓名输出set集合里面的内容就可以。

注意:

如果用string字符串来存储学生姓名,由于cin、cout等操作十分耗时,所以最后一个测试用例超时,此时应该用散列,将姓名转化为对应的数字。

由于三个字母一共有26*26*26种排序方法,以及十种数字(0-9),例如AAA1就可以是(1+26*1+1*26*26)*10+1,BBC9就可以是(3+26*2+2*26*26)*10+9,这样就将姓名转化成唯一的数字。

利用map<int,set<int> >进行映射。

完整代码:

#include<iostream>
#include<map>
#include<set>
#include<string>
using namespace std;
map<int,set<int> >m;

int getid(char *s){
	int n;
	n += s[3] - '0';
	n += (s[2] - 'A')*10;
	n += (s[1] - 'A')*26*10;
	n += (s[0] - 'A')*26*26*10;
	return n;
}

int main(){
	int N,K;
	int i,j,c,n;
	char s[4];
	int id;
	cin>>N>>K;
	for(i=0;i<K;i++){
		scanf("%d %d",&c,&n);
		for(j=0;j<n;j++){
			scanf("%s",s);
			id = getid(s);
			m[id].insert(c);
		}
	}
	
	for(i=0;i<N;i++){
		scanf("%s",&s);
		printf("%s ",s);
		id = getid(s);
		printf("%d",m[id].size());
		set<int>::iterator it;
		for(it=m[id].begin();it!=m[id].end();it++){
			cout<<" "<<*it;
		}
		cout<<endl;
	}
	
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值