【PAT(甲级)】1039 Course List for Student

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni​ (≤200) are given in a line. Then in the next line, Ni​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

解题思路:

题目给出总人数N,总课程数量K(编号1-K)。接下来每行先给出课程编号,和选这门课的人数。最后给出N个查课人数,按照查课的顺序先后输出每个人的选课数量和选课的课程编号。

字符串和数字类型匹配的题目,直接用map。然后因为一个课对应多个人,一个人可以选多门课,是一对多。所以用vector来存储。

最后输出即可。

这一题不难,但是会用到迭代器的思想,可以自己找资料学一下,用起来还是挺简单的。

易错点:

1. 记得用vector别用set来存储,set太大了会超内存的。

代码:

#include<bits/stdc++.h>
using namespace std;
int N;//学生数量
int K;//课程数量 

int main(){
	cin>>N>>K;
	map<int,vector<string>> course;//存储每门课程对应的学生姓名 
	for(int i=0;i<K;i++){
		int a,b;
		cin>>a>>b;
		for(int j=0;j<b;j++){
			string temp;
			cin>>temp;
			course[a].push_back(temp);
		}
	} 
	
	string name[N];
	for(int i=0;i<N;i++){
		cin>>name[i];
	}
	
	map<string,vector<int>> student;
	
	for(auto i=course.begin();i!=course.end();i++){
		string name;int temp;
		temp = i->first;
		for(auto j=i->second.begin();j!=i->second.end();j++){
			student[*j].push_back(temp);
		}
	}
	
	for(int i=0;i<N;i++){
		cout<<name[i]<<" ";
		if(student.count(name[i])>0){//找到这个人的名字 
			auto t = student.find(name[i]);
			cout<<t->second.size();
			if(t->second.size()){
				for(auto j = t->second.begin();j!=t->second.end();j++){
					cout<<" "<<*j;
				}
			}
		}
		else{//找不到说明没选课,输出0 
			cout<<"0";
		}
		cout<<endl;
	}
	
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值