甲级PAT 1077 Kuchiguse (20 分)(公共后缀)

1077 Kuchiguse (20 分)

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)

  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

题目要求: 

找出字符串中公共的后缀。如果没有输出nai

解题思路:

首先存储第一个字符串的最后一个字符,然后与后续每个字符串最后一个字符比较,如果全部相等,公共字符串的num+1,然后再比较倒数第二个字符,依次向前。如果存在有一个字符串对应位置的字符不相等则结束。

注意:

1.不光考虑字符不相等的时候这一结束条件,还得考虑是否有字符串已经遍历完了。否则最后一个测试点报运行时错误

因为有一种情况

2

0

0

这样光考虑有不同字符结束的话,对于所有字符串都没有不同字符的情况则无法结束,所以还得判断是否有字符串结束了。

2.如果用getline(cin,str)读取一行字符串的时候,是需要在cin>>n之后加个getchar()读取掉'\n'字符,否则getline得到的第一个字符串是回车。

完整代码:

#include<iostream>
#include<cstring>
#include<string>
using namespace std;

int main(){
	int n,i,l,num=0;
	string s[110];
	char c;
	bool same=true,conti=true;;
	cin>>n;
	getchar();
	for(i=0;i<n;i++) getline(cin,s[i]);
	while(same && conti){
		l=s[0].length()-1;
		if(l-num<0) conti=false;
		else c=s[0][l-num];
		for(i=1;i<n;i++){
			l=s[i].length()-1;
			if(l-num<0) {
				conti=false;
				break;
			}
			if(s[i][l-num] !=c){
				same = false;
				break;
			}
		}
		if(same && conti) num++;
	}
	if(num>0){
		l=s[0].length();
		cout<<s[0].substr(l-num,num);
	}else{
		cout<<"nai";
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值