PAT 1077 Kuchiguse [字符串处理] [字符串反转的三种方法]

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)

  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

 

我的代码: 

1.gets函数在C++下提交居然编译错误了,查了下PAT只有C语言支持gets函数。C++就用getline(cin,s)吧!

2.字符串的反转

①普普通通老老实实法

for(j=0;j<len/2;j++)

{
        char tmp = s[i][j];
        s[i][j] = s[i][len-1-j];
        s[i][len-1-j] = tmp;
}

②char类型的字符串,可用string.h中的strrev函数

strrev(s[i]); 

但是!PAT无论是C还是C++都无法编译这个函数!为什么啊!!!

③string类型的字符串,可用algorithm中的reverse函数

reverse(s.begin(),s.end());

 

//用了gets函数,只能C运行啦
#include<stdio.h>
#include<string.h>

int main()
{
	int n,i,j,minLen = 300;
	char s[105][300];
	scanf("%d",&n);
	//输入n后有一个换行符需要吃掉,不然gets会少读取 
	getchar();
	for(i=0;i<n;i++)
	{
		gets(s[i]);
		int len = strlen(s[i]);
		if(len<minLen) minLen = len;
		//就地逆转字符串 方法① 
		for(j=0;j<len/2;j++)
		{
			char tmp = s[i][j];
			s[i][j] = s[i][len-1-j];
			s[i][len-1-j] = tmp;
		}
		//strrev(s[i]); 方法②(可惜在PAT下C和C++都编译错误 
	}
	int flag = 0,count = 0;
	//minLen为了避免扫描到最短字符串外头去了 
	for(i=0;i<minLen;i++)
	{
		char same = s[0][i];
		for(j=0;j<n;j++)
		{
			if(s[j][i]!=same)
			{
				flag = 1;
				break;
			}	
		}
		if(flag) break;
		else count++;		
	}
	if(count)
	{
		for(i=count-1;i>=0;i--)
			printf("%c",s[0][i]);
	}
	else printf("nai");
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值