甲级PAT 1088 Rational Arithmetic (20 分)(分数四则运算)

1088 Rational Arithmetic (20 分)

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

题目要求 

给定两个分数做加减乘除四则运算,按要求输出,输出分数要化简,对于分母为0的分数要输出Inf,对于负数要加括号()

注意

1.分子和分母要用long long,因为存在乘超过范围的情况;

2.分母为0的情况要输出Inf,

完整代码

#include<bits/stdc++.h>
using namespace std;
struct Fraction{
	long long up,down;
};

long long gcd(long long a,long long b){
	if(a<b) swap(a,b);
	if(b==0) return a;
	else return gcd(b,a%b);
}

Fraction reduct(Fraction f){
	if(f.down<0){
		f.up=-f.up;
		f.down=-f.down;
	}
	if(f.up==0) f.down=1;
	long long d=gcd(abs(f.up),f.down);
	f.up/=d;
	f.down/=d;
	return f;
}

Fraction add(Fraction f1,Fraction f2){
	Fraction f3;
	f3.up=f1.up*f2.down+f2.up*f1.down;
	f3.down=f1.down*f2.down;
	return reduct(f3);
}

Fraction sub(Fraction f1,Fraction f2){
	Fraction f3;
	f3.up=f1.up*f2.down-f2.up*f1.down;
	f3.down=f1.down*f2.down;
	return reduct(f3);
}

Fraction mul(Fraction f1,Fraction f2){
	Fraction f3;
	f3.up=f1.up*f2.up;
	f3.down=f1.down*f2.down;
	return reduct(f3);
}

Fraction div(Fraction f1,Fraction f2){
	Fraction f3;
	f3.up=f1.up*f2.down;
	f3.down=f1.down*f2.up;
	return reduct(f3);
}

void print(Fraction f){
	if(f.down==0) printf("Inf");
	else if(f.up==0) printf("0");
	else if(f.up<0){
		if(abs(f.up)/f.down>=1 ){
			if(abs(f.up)%f.down==0) printf("(%lld)",f.up/f.down);
			else printf("(%lld %lld/%lld)",f.up/f.down,abs(f.up)%f.down,f.down);
		}else printf("(%lld/%lld)",f.up,f.down);
	}else if(f.up>0){
		if(abs(f.up)/f.down>=1 ){
			if(abs(f.up)%f.down==0) printf("%d",f.up/f.down);
			else printf("%lld %lld/%lld",f.up/f.down,abs(f.up)%f.down,f.down);
		}else printf("%lld/%lld",f.up,f.down);
	}
}

int main(){
	Fraction f1,f2,r[4];
	char c[5]={'+','-','*','/'};
	scanf("%lld/%lld %lld/%lld",&f1.up,&f1.down,&f2.up,&f2.down);
	f1=reduct(f1);
	f2=reduct(f2);
	r[3]=div(f1,f2);
	r[2]=mul(f1,f2);
	r[1]=sub(f1,f2);
	r[0]=add(f1,f2);
	for(int i=0;i<4;i++){
		print(f1);
		printf(" %c ",c[i]);
		print(f2);
		printf(" = ");
		print(r[i]);
		printf("\n");
	}	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值