(PAT 1088) Rational Arithmetic (分数运算模拟)

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

解题思路:

模拟分数的运算,比较繁琐的模拟题,代码量较大

我在一个地方卡了比较久,分子分母相同的情况,不能直接输出1,因为可能存在为-1的情况,要输出计算结果

#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <algorithm>
#include <math.h>
#include <string>
using namespace std;
struct refs {
	long long up, down;
};

long long gcd(long long a, long long b) {
	if (b == 0) return a;
	else return gcd(b, a%b);
}

refs simplify(refs obj) {
	if (obj.up == 0) {
		obj.up = 0, obj.down = 1;
		return obj;
	}
	if (obj.down < 0) { //交换负数
		obj.up = -obj.up;
		obj.down = -obj.down;
	}
	long long gcdNum = gcd(abs(obj.up), abs(obj.down));
	obj.up /= gcdNum;
	obj.down /= gcdNum;
	return obj;
}

refs sadd(refs obj1,refs obj2) {
	refs obj;
	obj.down = obj1.down*obj2.down;
	obj.up = obj1.up*obj2.down + obj2.up*obj1.down;
	return simplify(obj);
}

refs ssub(refs obj1, refs obj2) {
	refs obj;
	obj.down = obj1.down*obj2.down;
	obj.up = obj1.up*obj2.down - obj2.up*obj1.down;
	return simplify(obj);
}

refs smulty(refs obj1, refs obj2) {
	refs obj;
	obj.down = obj1.down*obj2.down;
	obj.up = obj1.up * obj2.up;
	return simplify(obj);
}

refs sdiv(refs obj1, refs obj2) {
	refs obj;
	obj.up = obj1.up * obj2.down;
	obj.down = obj1.down*obj2.up;
	return simplify(obj);
}

void showRes(refs sobj) {
	if (sobj.up == 0) {
		printf("0");
	}
	else if (sobj.down == 0) {
		printf("Inf");
	}
	else {
		if (sobj.up < 0) printf("(");
		if (abs(sobj.up) > abs(sobj.down)) {
			if (abs(sobj.up) % abs(sobj.down) == 0) {
				printf("%lld", sobj.up / sobj.down);
			}
			else {
				printf("%lld %lld/%lld", sobj.up / sobj.down, abs(sobj.up % sobj.down), abs(sobj.down));
			}
		}
		else if(abs(sobj.up) == abs(sobj.down)){
			printf("%lld", sobj.up/sobj.down);
		}
		else {
			printf("%lld/%lld", sobj.up, sobj.down);
		}
		if (sobj.up < 0) printf(")");
	}
}

int main() {
	refs input1, input2;
	scanf("%lld/%lld %lld/%lld", &input1.up, &input1.down, &input2.up, &input2.down);
	refs obbj[4];
	char tools[4] = { '+','-','*','/' };
	int index = 0;
	obbj[index++]= sadd(input1, input2);
	obbj[index++] = ssub(input1, input2);
	obbj[index++] = smulty(input1, input2);
	obbj[index++] = sdiv(input1, input2);
	//化简input
	refs sinput1, sinput2;
	sinput1 = simplify(input1);
	sinput2 = simplify(input2);
	
	for (int i = 0; i < 4; ++i) {
		showRes(sinput1);
		printf(" %c ", tools[i]);
		showRes(sinput2);
		printf(" = ");
		showRes(obbj[i]);
		printf("\n");
	}
	
	system("PAUSE");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值