甲级PAT 1143 Lowest Common Ancestor (30 分)(LCA)

1143 Lowest Common Ancestor (30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题目要求 

对于给定序列按顺序构造一棵二叉查找树,然后找到给定结点的深层的公共祖先(也就是最近的公共祖先)

有四种格式

1.要查找的两个结点都不在树中,输出ERROR: 12 and -3 are not found.

2.要查找的其中一个结点不在树中,输出ERROR: 0 is not found.

3.查找的结点存在,也有祖先,但是祖先是两个结点其中的一个,输出8 is an ancestor of 7.

4.一般情况,输出8 is an ancestor of 7.

解题思路

由于是二叉查找树,对于两个结点u,v的最近公共祖先t,可能一个u和v分布在t的两边,即(u<t && v>t)或(u>t && v<t),还有可能是u是v的最近公共祖先,即t==u,或者t==v

由于这里可能输入的结点不在树里,用一个map来表示结点存在情况

完整代码

#include<bits/stdc++.h>
using namespace std;

int main(){
	int m,n,i,j,u,v,t;
	map<int,bool> exist;
	scanf("%d %d",&m,&n);
	vector<int> pre(n);
	for(i=0;i<n;i++){
		scanf("%d",&pre[i]);
		exist[pre[i]]=true;
	}
	while(m--){
		scanf("%d %d",&u,&v);
		for(i=0;i<n;i++){
			t=pre[i];
			if((t>u && t<v) || (t>v && t<u) ) break;
			if(t==u || t==v) break;
		}
		if(exist[u]==false && exist[v]==false) printf("ERROR: %d and %d are not found.\n",u,v);
		else if(exist[u]==true && exist[v]==true){
			if(t==u || t==v) printf("%d is an ancestor of %d.\n",t,t==u?v:u);
			else printf("LCA of %d and %d is %d.\n",u,v,t);
		}else printf("ERROR: %d is not found.\n",exist[u]==false?u:v);
	} 	
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值