PAT_ (树补充)一般二叉树的LCA(Median) BST的LCA(Easy)

目录

1143 Lowest Common Ancestor (30分)

235. 二叉搜索树的最近公共祖先               

对于上题,在给定BST的先序遍历序列时,相当于省掉了dfs这步,

1151 LCA in a Binary Tree (30分)


1143 Lowest Common Ancestor (30分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.
显然BST左小右大的性质+前序遍历序列 可以唯一确定一颗二叉树

 

题⽬⼤意:给出⼀棵⼆叉搜索树的前序遍历,问结点uv的共同最低祖先是谁

分析: map<int, bool> mp ⽤来标记树中所有出现过的结点,遍历⼀遍 pre 数组,将当前结点标记为 a , 如果u和 v 分别在 a 的左、右,或者 u v 其中⼀个就是当前 a ,即 (a >= u && a <= v) || (a >= v && a <= u) , 说明找到了这个共同最低祖先a,退出当前循环~最后根据要求输出结果即可

#include <iostream>
#include <vector>
#include <map>
using namespace std;
map<int, bool> mp;
int main() {
     int m, n, u, v, a;
     scanf("%d %d", &m, &n);
     vector<int> pre(n);
     for (int i = 0; i < n; i++) {
         scanf("%d", &pre[i]);
         mp[pre[i]] = true;
     }
     for (int i = 0; i < m; i++) {
         scanf("%d %d", &u, &v);
         for(int j = 0; j < n; j++) {
             a = pre[j];
             if ((a >= u && a <= v) || (a >= v && a <= u)) break;
         }
         if (mp[u] == false && mp[v] == false)
             printf("ERROR: %d and %d are not found.\n", u, v);
         else if (mp[u] == false || mp[v] == false)
             printf("ERROR: %d is not found.\n", mp[u] == false ? u : v);
         else if (a == u || a == v)
             printf("%d is an ancestor of %d.\n", a, a == u ? v : u);
         else
             printf("LCA of %d and %d is %d.\n", u, v, a);
     }
     return 0; 
}

235. 二叉搜索树的最近公共祖先               

对于上题,在给定BST的先序遍历序列时,相当于省掉了dfs这步,

/*Definition for a binary tree node.
 public class TreeNode {
     int val;
     TreeNode left;
     TreeNode right;
    TreeNode(int x) { val = x; }
 }*/
class Solution {
    public TreeNode lowestCommonAncestor(TreeNode root, TreeNode p, TreeNode q) {

        int parentVal = root.val;
        int pVal = p.val; 
        int qVal = q.val;

        if (pVal > parentVal && qVal > parentVal) {
            // If both p and q are greater than parent
            return lowestCommonAncestor(root.right, p, q);
        } else if (pVal < parentVal && qVal < parentVal) {
            // If both p and q are lesser than parent
            return lowestCommonAncestor(root.left, p, q);
        } else {
            // We have found the split point, i.e. the LCA node.
            return root;
        }
    }
}

236. 一般二叉树的最近公共祖先   https://blog.csdn.net/weixin_43107805/article/details/105350545

1151 LCA in a Binary Tree (30分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.
题⽬⼤意:给出中序序列和先序序列,再给出两个点,求这两个点的最近公共祖先
分析:不⽤建树~已知某个树的根结点,
ab在根结点的左边,则ab的最近公共祖先在当前⼦树根结点的左⼦树寻找,
如果ab在当前⼦树根结点的两边,在当前⼦树的根结点就是ab的最近公共祖先,
如果ab在当前⼦树根结点的右边,则ab的最近公共祖先就在当前⼦树的右⼦树寻找。
中序加先序可以唯⼀确定⼀棵树,在不构建树的情况下,在每⼀层的递归中,可以得到树的根结点 在此时并⼊lca算法 可以确定两个结点的公共祖先

注意:本题的注意点是pos[]数组的利用 

#include <iostream>
#include <vector>
#include <map>
using namespace std;
map<int, int> pos;
vector<int> in, pre;
void lca(int inl, int inr, int preRoot, int a, int b) {
     if (inl > inr) return;
     int inRoot = pos[pre[preRoot]], aIn = pos[a], bIn = pos[b];
     if (aIn < inRoot && bIn < inRoot)
         lca(inl, inRoot-1, preRoot+1, a, b);
     else if ((aIn < inRoot && bIn > inRoot) || (aIn > inRoot && bIn < inRoot))
         printf("LCA of %d and %d is %d.\n", a, b, in[inRoot]);
     else if (aIn > inRoot && bIn > inRoot)
         lca(inRoot+1, inr, preRoot+1+(inRoot-inl), a, b);
     else if (aIn == inRoot)
         printf("%d is an ancestor of %d.\n", a, b);
     else if (bIn == inRoot)
         printf("%d is an ancestor of %d.\n", b, a);
}
int main() {
     int m, n, a, b;
     scanf("%d %d", &m, &n);
     in.resize(n + 1), pre.resize(n + 1);
     for (int i = 1; i <= n; i++) {
         scanf("%d", &in[i]);
         pos[in[i]] = i;  //存index
     }
     for (int i = 1; i <= n; i++) scanf("%d", &pre[i]);
     for (int i = 0; i < m; i++) {
         scanf("%d %d", &a, &b);
         if (pos[a] == 0 && pos[b] == 0)
             printf("ERROR: %d and %d are not found.\n", a, b);
         else if (pos[a] == 0 || pos[b] == 0)
             printf("ERROR: %d is not found.\n", pos[a] == 0 ? a : b);
         else
             lca(1, n, 1, a, b);
     }
     return 0; 
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值