1066 Root of AVL Tree (25 分)
An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.
Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the root of the resulting AVL tree in one line.
Sample Input 1:
5
88 70 61 96 120
Sample Output 1:
70
Sample Input 2:
7
88 70 61 96 120 90 65
Sample Output 2:
88
题目要求
根据序列构建一棵平衡二叉树,输出平衡二叉树的根结点值
解题思路
对着构建AVL套模板就好了。。
参考算法笔记
完整代码
#include<bits/stdc++.h>
using namespace std;
struct node{
int v,height;
struct node *lchild,*rchild;
};
node* newNode(int v){
node* temp=new node;
temp->height=1;
temp->v=v;
temp->lchild=temp->rchild=NULL;
return temp;
}
int getHeight(node* root){
if(root==NULL) return 0;
else return root->height;
}
int getBF(node* root){
return getHeight(root->lchild)-getHeight(root->rchild);
}
void updateHeight(node* &root){
root->height = max(getHeight(root->lchild),getHeight(root->rchild))+1;
}
void L(node* &root){
node* temp=root->rchild;
root->rchild=temp->lchild;
temp->lchild=root;
updateHeight(root);
updateHeight(temp);
root=temp;
}
void R(node* &root){
node* temp=root->lchild;
root->lchild=temp->rchild;
temp->rchild=root;
updateHeight(root);
updateHeight(temp);
root=temp;
}
void insert(node* &root,int v){
if(root==NULL){
root=newNode(v);
return;
}
if(v < root->v){
insert(root->lchild,v);
updateHeight(root);
if(getBF(root)==2){
if(getBF(root->lchild)==1){
R(root);
}else if(getBF(root->lchild)==-1){
L(root->lchild);
R(root);
}
}
}else{
insert(root->rchild,v);
updateHeight(root);
if(getBF(root)==-2){
if(getBF(root->rchild)==-1){
L(root);
}else if(getBF(root->rchild)==1){
R(root->rchild);
L(root);
}
}
}
}
node* create(int data[],int n){
node* root=NULL;
for(int i=0;i<n;i++){
insert(root,data[i]);
}
return root;
}
int main(){
int n,i,a[50];
cin>>n;
for(i=0;i<n;i++) cin>>a[i];
node* root=create(a,n);
cout<<root->v;
return 0;
}