PAT-1066 Root of AVL Tree

1066 Root of AVL Tree (25)(25 分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

 

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

  平衡二叉树插入元素后的旋转问题,每插入一个元素需要从下到上依次调整插入路径上的非平衡节点,所以插入函数用递归比较方便。根据非平衡节点的类型分为LL,LR,RR,RL型。分别进行对应的左旋和右旋操作可以调整平衡。

#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
int num[25]; 

typedef struct node{
	int val,height;
	node *left,*right;
}node;
node* newnode(int v){
	node* n=(node*)malloc(sizeof(node));
	n->height=1;
	n->val=v;
	n->left=NULL;
	n->right=NULL;
	return n;
}
int geth(node *&root){
	if(root==NULL)
		return 0;
	return root->height;
}
void updateH(node *&root){
	root->height=std::max(geth(root->left),geth(root->right))+1;
}
int getBanFac(node *&n){
	if(n==NULL)
		return 0;
	return geth(n->left)-geth(n->right);
}
void left(node *&root){//左旋
	node *tmp=root->right;
	root->right=tmp->left;
	tmp->left=root;
	updateH(root);//先更新下面的
	updateH(tmp);//再更新上面的
	root=tmp;
}
void right(node *&root){//右旋
	node *tmp=root->left;
	root->left=tmp->right;
	tmp->right=root;
	updateH(root);//先更新下面的
	updateH(tmp);//再更新上面的
	root=tmp;
}
void insertn(node *&n,int v){
	if(n==NULL){
		n=newnode(v);
		return;
	}
	if(n->val>v){
		insertn(n->left,v);
		updateH(n);
		int fac1=getBanFac(n);
		int fac2=getBanFac(n->left);
		if(fac1==2){
			if(fac2==1){//LL
				right(n);
			}else if(fac2==-1){//LR
				left(n->left);
				right(n);
			}
		}
	}else{
		insertn(n->right,v);
		updateH(n);
		int fac1=getBanFac(n);
		int fac2=getBanFac(n->right);
		if(fac1==-2){
			if(fac2==-1){//RR
				left(n);
			}else if(fac2==1){//RL
				right(n->right);
				left(n);
			}
		}
	}
}

int main(){
	int t;
	scanf("%d",&t);
	for(int i=0;i<t;i++){
		scanf("%d",num+i);
	}
	node* root=NULL;
	for(int i=0;i<t;i++){
		insertn(root,num[i]);
	}

	printf("%d",root->val);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值