甲级PAT 1052 Linked List Sorting (25 分)(链表)

1052 Linked List Sorting (25 分)

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (<10​5​​) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−10​5​​,10​5​​], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

题目要求 

给出一个链表的起始点,然后给出多个相互连接的段,输出从起始点开始从小到大排序的新链表

解题思路

这里用数组下标代表结点对应的id,里面存储它的下一结点Id,从起始点开始遍历,将对应的id加入到向量中,然后根据结点的权值进行从小到大排序,然后按顺序输出就可以了。

注意

存在一个起始点没有对应链表的情况,这时候要输出0 -1

完整代码

#include<bits/stdc++.h>
using namespace std;

struct Node{
	int data,next;
}node[100010];
vector<int> linklist;

bool com(int i,int j){
	return node[i].data<node[j].data;
}

int main(){
	int n,start,i,u,v,d;
	cin>>n>>start;
	for(i=0;i<n;i++){
		cin>>u>>d>>v;
		node[u].data=d;
		node[u].next=v;
	}
	while(start!=-1){
		linklist.push_back(start);
		start=node[start].next;
	}
	if(linklist.size()==0){
	  cout<<0<<" "<<-1;
	  return 0;
	}
	sort(linklist.begin(),linklist.end(),com);
	printf("%d %05d\n",linklist.size(),linklist[0]);
	for(i=0;i<linklist.size();i++){
	  int now=linklist[i];
		if(i!=linklist.size()-1) printf("%05d %d %05d\n",now,node[now].data,linklist[i+1]);
		else printf("%05d %d -1\n",now,node[now].data);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值