甲级PAT 1063 Set Similarity (25 分)(集合,set)

1063 Set Similarity (25 分)

Given two sets of integers, the similarity of the sets is defined to be N​c​​/N​t​​×100%, where N​c​​ is the number of distinct common numbers shared by the two sets, and N​t​​ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10​4​​) and followed by M integers in the range [0,10​9​​]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

题目说明以后补。

完整代码 

#include<bits/stdc++.h>
using namespace std;
vector<set<int> > a(60);

int getnc(int u,int v){
	set<int>::iterator itu=a[u].begin();
	set<int>::iterator itv=a[v].begin();
	int num=0;
	while(itu!=a[u].end() && itv!=a[v].end()){
		if(*itu<*itv) itu++;
		else if(*itu>*itv) itv++;
		else{
			num++;
			itu++;
			itv++;
		}
	}
	return num;	
}

int getnt(int u,int v){
	set<int>::iterator itu=a[u].begin();
	set<int>::iterator itv=a[v].begin();
	int num=0;
	while(itu!=a[u].end() && itv!=a[v].end()){
		if(*itu<*itv) itu++;
		else if(*itu>*itv) itv++;
		else{
			itu++;
			itv++;
		}
		num++;
	}
	while(itu!=a[u].end()){
		itu++;
		num++;
	} 
	while(itv!=a[v].end()){
		itv++;
		num++;
	} 
	return num;	
}


int main(){
	int n,m,i,j,temp,k,u,v;
	cin>>n;
	for(i=1;i<=n;i++){
		cin>>m;
		for(j=0;j<m;j++){
			cin>>temp;
			a[i].insert(temp);
		}
	}
	cin>>k;
	for(i=0;i<k;i++){
		cin>>u>>v;
		int nc=getnc(u,v);
		int nt=getnt(u,v);
		printf("%.1f\%\n",(double)nc/nt*100);
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值