多校4 The All-purpose Zero 5773

The All-purpose Zero

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1503    Accepted Submission(s): 717


Problem Description
?? gets an sequence S with n intergers(0 < n <= 100000,0<= S[i] <= 1000000).?? has a magic so that he can change 0 to any interger(He does not need to change all 0 to the same interger).?? wants you to help him to find out the length of the longest increasing (strictly) subsequence he can get.
 

Input
The first line contains an interger T,denoting the number of the test cases.(T <= 10)
For each case,the first line contains an interger n,which is the length of the array s.
The next line contains n intergers separated by a single space, denote each number in S.
 

Output
For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the length of the longest increasing subsequence he can get.
 

Sample Input
  
  
2 7 2 0 2 1 2 0 5 6 1 2 3 3 0 0
 

Sample Output
  
  
Case #1: 5 Case #2: 5
Hint
In the first case,you can change the second 0 to 3.So the longest increasing subsequence is 0 1 2 3 5.
 

题意:给你一串序列,0可以变成任何数,问最长上升子序列

思路:nlogn 的LIS改编一下,遇到0把之前的i长度的子序列的最后一个值都改成i-1长度的子序列的最后一个值+1(为了让他尽量小)


代码:

#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include <iostream>

using namespace std;
int a[100010];
int d[100010];

int main(){
    int t;
    scanf("%d",&t);
    int ca = t;
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;++i)
            scanf("%d",&a[i]);
        int len = 1;
        d[0] = -1;
        for(int i = 1; i <= n; ++i)
        {
             if(a[i] == 0)
             {
                 for(int j = len;  j > 0; j--)
                     d[j] = d[j-1] + 1;
                 len++;
             }
             else
             {
                 if(a[i] > d[len - 1])
                     d[len++] = a[i];
                 else
                     d[lower_bound(d + 1,d+len,a[i])-d] = a[i];
             }
        }
        printf("Case #%d: %d\n",ca-t,len-1);
    }
    return 0;    
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值