多校3 5761 Rower Bo

Rower Bo

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1327    Accepted Submission(s): 506
Special Judge


Problem Description
There is a river on the Cartesian coordinate system,the river is flowing along the x-axis direction.

Rower Bo is placed at (0,a) at first.He wants to get to origin (0,0) by boat.Boat speed relative to water is v1 ,and the speed of the water flow is v2 .He will adjust the direction of v1 to origin all the time.

Your task is to calculate how much time he will use to get to origin.Your answer should be rounded to four decimal places.

If he can't arrive origin anyway,print"Infinity"(without quotation marks).
 

Input
There are several test cases. (no more than 1000)

For each test case,there is only one line containing three integers a,v1,v2 .

0a100 , 0v1,v2,100 , a,v1,v2 are integers
 

Output
For each test case,print a string or a real number.

If the absolute error between your answer and the standard answer is no more than 104 , your solution will be accepted.
 

Sample Input
  
  
2 3 3 2 4 3
 

Sample Output
  
  
Infinity 1.1428571429
 
题意:物理..一条船过河(位于y轴到原点),速度时刻朝向原点...英语大渣竟然没看懂这句话,给船速水速求时间,

思路:大物...V分1,V分2列方程: (V船cosα-V水)dt = 0,(V船-V水cosα)dt = 0;解方程..

            因为要约掉cosα所以 V分2不能列垂直方向上的方程(垂直出来sinα)

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>

using namespace std;

int main()
{
    double a,x,y;
    while(cin>>a>>x>>y)
    {
        if(a)
        {
            if(x > y)
                printf("%.6f\n",a/(x-(y*y/x)));
            else
                cout<<"Infinity"<<endl;
        }
        else
            cout<<0.000000<<endl;
    }
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值