《ACM程序设计》书中题目K(爱搭积木的小鲍勃)

Description

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all stacks the same height. Then you would have a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?


Input

The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.


Output

For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.'', where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height.

Output a blank line after each set.


Sample Input

6
5 2 4 1 7 5
0


Sample Output

Set #1

The minimum number of moves is 5.


题目大概是讲小鲍勃爱乱搭积木,但是搭的参差不齐,他姐姐认为他应该把积木都搭的一样高,计算最少挪几次才能都一样高。

开始时想逐个扫描,最高的搭到最矮的上面,一样高时停止并输出移动次数;

但是这样可能会超时,所以可以反向考虑;


大体思路是这样的:

1.首先计算出最后的情况,也就是平均高度;

2.用高于这些的积木墙高度减去平均高度(反之亦然),可以等同于把高的移到矮的上面;

3.得到的差全部加起来,就是移动的最少次数了。


程序如下:

#include<bits/stdc++.h>
using namespace std;
int main()
{
        int i,avrg,high[55],mov,n,a=1;
        while(cin>>n)
        {
                if(n==0)
                        break;
                else
                {
                        avrg=mov=0;
                        for(i=0;i<n;i++)
                        {
                                cin>>high[i];
                                avrg+=high[i];
                        }
                        avrg/=n;
                        for(i=0;i<n;i++)
                        {
                                if(high[i]>avrg)
                                        mov+=high[i]-avrg;
                        }
                        cout<<"Set #"<<a<<endl<<"The minimum number of moves is "<<mov<<"."<<endl<<endl;
                }
                a++;
        }
}

题目没什么太难的地方,除了输出时格式的问题多尝试了几次外,没什么问题。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值