《ACM程序设计》书中题目W(让草坪变美丽吧,Tom!)

Description

Tom's Meadow 

Tom has a meadow in his garden. He divides it into N * M squares. Initially all the squares were covered with grass. He mowed down the grass on some of the squares and thinks the meadow is beautiful if and only if

  1. Not all squares are covered with grass.
  2. No two mowed squares are adjacent.

Two squares are adjacent if they share an edge. Here comes the problem: Is Tom's meadow beautiful now?

Input

The input contains multiple test cases!

Each test case starts with a line containing two integers NM (1 <= NM <= 10) separated by a space. There follows the description of Tom's Meadow. There're N lines each consisting of M integers separated by a space. 0(zero) means the corresponding position of the meadow is mowed and 1(one) means the square is covered by grass.

A line with N = 0 and M = 0 signals the end of the input, which should not be processed

Output

One line for each test case.

Output "Yes" (without quotations) if the meadow is beautiful, otherwise "No"(without quotations).

Sample Input

2 2
1 0
0 1
2 2
1 1
0 0
2 3
1 1 1
1 1 1
0 0

Sample Output

Yes
No
No


题目大意是说一块草坪分为几行几列的块,有的块会进行修剪(表示为0),草坪美丽的标准是1.修剪过,2.修剪过的块不能相连;

思路如下:

1.建立二维字符数组来保存每一块的状态;

2.因为数据不大,可以逐个判定,不用怕超时,判定的方式是:

    ①没有遇到0,不美丽;

    ②遇到0,检查周围数据,有0,不美丽,没有0,继续检查,若最后检查完毕,美丽;

程序如下:

#include<bits/stdc++.h>
using namespace std;
int main()
{
        char a[15][15];
        int m,n,i,j,x;
        while(cin>>m>>n)
        {
                if(m==0)            //输0 0结束循环
                        break;
                else
                {
                        x=0;
                        memset(a,0,sizeof(a));       //清空数组
                        for(i=1;i<=m;i++)
                                for(j=1;j<=n;j++)
                                        cin>>a[i][j];
                        for(i=1;i<=m;i++)
                                for(j=1;j<=n;j++)
                                {
                                        if(a[i][j]=='0')        //遇0判断
                                        {
                                                x++;
                                                if(a[i-1][j]=='0'||a[i+1][j]=='0'||a[i][j-1]=='0'||a[i][j+1]=='0')
                                                {
                                                        x=0;
                                                        goto A;
                                                }
                                        }
                                }
                        A:
                        if(x==0)          //可能是没有遇到0,也可能是00相邻,草坪不美丽
                                cout<<"No"<<endl;
                        else
                                cout<<"Yes"<<endl;
                }
        }
}

这道题因为输出写了大写好几次没过,嗨呀好气啊>.<!!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值