ZOJ - 2850

 
Tom's Meadow 

Tom has a meadow in his garden. He divides it into N * M squares. Initially all the squares were covered with grass. He mowed down the grass on some of the squares and thinks the meadow is beautiful if and only if

  1. Not all squares are covered with grass.
  2. No two mowed squares are adjacent.

Two squares are adjacent if they share an edge. Here comes the problem: Is Tom's meadow beautiful now?

汤姆在他的花园里有一片草地。 他将它分成N * M个正方形。 最初所有的广场都被草覆盖着。 他在一些广场上修剪草地,并认为草地是美丽的,当且仅当


并非所有的广场都被草覆盖。

没有两个割草方格相邻。

如果两个方格共享一个边,则它们相邻。 问题来了:汤姆的草地现在变得漂亮了吗?

Input

The input contains multiple test cases!

Each test case starts with a line containing two integers NM (1 <= NM <= 10) separated by a space. There follows the description of Tom's Meadow. There're N lines each consisting of M integers separated by a space. 0(zero) means the corresponding position of the meadow is mowed and 1(one) means the square is covered by grass.

A line with N = 0 and M = 0 signals the end of the input, which should not be processed

输入包含多个测试用例!


每个测试用例都以包含由空格分隔的两个整数N,M(1 <= N,M <= 10)的行开始。 接下来是汤姆草地的描述。 每个N行由M个整数组成,每个行由一个空格分隔。 0(零)表示草地的相应位置被割草,1(1)表示广场被草地覆盖。


N = 0和M = 0的行表示输入的结束,不应该进行处理

Output

One line for each test case.

Output "Yes" (without quotations) if the meadow is beautiful, otherwise "No"(without quotations).

每个测试用例一行。


如果草地很漂亮,输出“是”(不含引号),否则输出“否”(不含引号)。

Sample Input

2 2
1 0
0 1
2 2
1 1
0 0
2 3
1 1 1
1 1 1
0 0

Sample Output

Yes
No
No


#include<stdio.h>
int n,m,i,j,c,k,d;


int a[15][15];
int fx[4]={0,0,-1,1};
int fy[4]={-1,1,0,0};
int fun(int x,int y)
{   
    int f=0;
for(k=0;k<4;k++)
{
int xx=x+fx[k];
int yy=y+fy[k];
if(xx>=0&&yy>=0&&xx<n&&yy<m&&a[xx][yy]==0)
{
f=1;break;

   }
   return f;
}


int main()
{
while(scanf("%d%d",&n,&m)!=EOF&&(n!=0||m!=0))
{
for(i=0;i<n;i++)
{
  for(j=0;j<m;j++)
  {
    scanf("%d",&a[i][j]);
  }
}
d=0;c=0;
for(i=0;i<n;i++)
{
for(j=0;j<m;j++)
{
if(a[i][j]==0)
{
c++;
d+=fun(i,j);  
}
}
}
if(c==0)
 printf("No\n");
else  if(d>=1)
 printf("No\n");
else
 printf("Yes\n");
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值