POJ 3295 Tautology 枚举 构造

 

 

Tautology
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5052 Accepted: 1910

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not

 

 题意:

离散数学的知识、、

给你一个 逻辑式 让你判断它是否是永真式;

逻辑式中 会出现 p q r s t 这几个变项 可赋值为 0或1

K:p && q

A:p || q

N:!p

C:!p || q

E:p==q?

思路:

5个变项 0 或1取值 共有 2^5=32种取值情况,可以用2进制表示;

对每一种取值情况 将值带入逻辑式 看能否成真 若都为真 则逻辑式为 永真式;

逻辑式的 计算:

建立一个栈 从逻辑式尾读取字符 若为变项 则将该变项对应的值 进栈;

若为 N 则 栈顶元素 出栈,取反进栈;

若为 其它 则 出栈 两个元素 并将 运算结果 进栈;

 

最后在栈中的一个元素的取值 若真 则该种 取值为 成真赋值;

否则 该逻辑式 不是 永真式,跳出;

#include <iostream>
#include <stack>
#include <bitset>
using namespace std;
char str[110];
void replace()
{
	for(int i=0; i<strlen(str); i++)
	{
		if(str[i]=='p') str[i]='0';
		else if(str[i]=='q') str[i]='1';
		else if(str[i]=='r') str[i]='2';
		else if(str[i]=='s') str[i]='3';
		else if(str[i]=='t') str[i]='4';
	}
}
int main()
{
	int i,j,t;
	bool x,y;
	while(gets(str))
	{
		if(str[0]=='0') return 0;
		replace();
		for(i=0,t=0; i<32; i++)
		{
			bitset<5>bit(i);
			stack<bool>Stack;
			for(j=strlen(str)-1;j>=0; j--)
			{
				if(str[j]>='0' && str[j]<='4')
					Stack.push(bit[str[j]-'0']);
				else if(str[j]=='N')
				{
					x = Stack.top(); Stack.pop();
					Stack.push(!x);
				}
				else 
				{
					x = Stack.top(); Stack.pop();
					y = Stack.top(); Stack.pop();
				}
				if(str[j]=='K')	Stack.push(x&&y);
				else if(str[j]=='A') Stack.push(x||y);
				else if(str[j]=='C') Stack.push((!x)||y);
				else if(str[j]=='E') Stack.push(x==y?1:0);
			}
			if(Stack.top()) t++;
			else break;
		}
		if(t==32) printf("tautology\n");
		else printf("not\n");
	}
	return 0;
}


一次AC 真爽、、

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值