POJ 2602 Superlong sums 大数加法

Superlong sums
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 20168 Accepted: 5842

Description

The creators of a new programming language D++ have found out that whatever limit for SuperLongInt type they make, sometimes programmers need to operate even larger numbers. A limit of 1000 digits is so small... You have to find the sum of two numbers with maximal size of 1.000.000 digits.

Input

The first line of an input file contains a single number N (1<=N<=1000000) - the length of the integers (in order to make their lengths equal, some leading zeroes can be added). It is followed by these integers written in columns. That is, the next N lines contain two digits each, divided by a space. Each of the two given integers is not less than 1, and the length of their sum does not exceed N.

Output

Output file should contain exactly N digits in a single line representing the sum of these two integers.

Sample Input

4
0 4
4 2
6 8
3 7

Sample Output

4750

 

题意: 输入N 代表 以下有N行

             第i (1<=i<=4)行 有两个数字 代表 大数a的第i个数字 和 大数b的第i个数字;

             输出 a+b 的值 注意!:不输出最高位的进位, 若有前导0也要输出!! 

思路: 一开始用JAVA 水 - - 没想到 JAVA TL了! 然后 C++模拟 用printf输出 orz ,TL!

然后 改成 puts() 输出 AC 1532MS、、、汗哒哒、、

以后 高精度不用 java了 没想到 C++码完 比JAVA短- -

#include <iostream>
using namespace std;
const int M = 1000001;
char a[M],b[M],ans[M];
int main()
{
	int n,i,temp,w;
	while(scanf("%d", &n)!=EOF)
	{
		getchar();
		for(i=n-1; i>=0; i--)
		{
			a[i] = getchar();
			getchar();
			b[i] = getchar();
			getchar();
		}
		for(i=0,w=0; i<n; i++)
		{
			temp = a[i]+b[i]-'0'-'0' + w;
			ans[n-i-1] = temp%10+'0';
			w = temp/10;
		}
		puts(ans);
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值