POJ 1789 Truck History 最小生成树Prim算法

Truck History
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10733 Accepted: 3971

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

 

题意: 有N个长度为7的字符串, 字符串由其他的字符串“衍生”出来的,a字符串由b衍生 则 它们之间的“衍生”花费为 a于b 中相同位置 不同字母的个数;

求 一个 衍生 方式 使得 衍生总花费 最小;

 

思路:假设N个字符串为 N个节点, 任意一个字符串 可以有 其他任意的字符串衍生出来, 则可以构成一个完全联通图;其中权值为 对应的衍生花费;

即 题目 所求 是 该图的 最小生成树的权值和;

 

Prim算法 1Y。感觉 是在写一个 包含N-1条边的最短路径 和 Dijkstra 太像了、、

#include <iostream>
using namespace std;
const int M = 2010;
char str[M][7];
int low[M],dis[M][M];
bool visit[M];
int n;
int getdis(int a, int b)
{
	int i,dis=0;
	for(i=0; i<7; i++)
	{
		if(str[a][i]!=str[b][i])
			dis++;
	}
	return dis;
}
int Prim()
{
	int pos=0,mindis,i,count=0,sumdis=0;
	for(i=0; i<n; i++)
	{
		low[i]=dis[pos][i]
		visit[i] = false;
	}
	visit[pos]=true; 
	low[pos]=0;
	while(count < n-1)
	{
		mindis = 8;
		for(i=0; i<n; i++)
		if(mindis>low[i] && !visit[i])
		{
			mindis = low[i];
			pos = i;
		}
		count++; visit[pos]=true;
		sumdis += low[pos];
		for(i=0; i<n; i++)
		{
			if(low[i]>dis[pos][i] && !visit[i])
				low[i] = dis[pos][i];
		}
	}
	return sumdis;
}
int main()
{
	int i,j;
	while(scanf("%d%*c", &n), n)
	{
		for(i=0; i<n; i++)
		{
			gets(str[i]);
			for(j=0; j<=i; j++)
				dis[i][j] = dis[j][i] = getdis(i,j);
		}
		printf("The highest possible quality is 1/%d.\n", Prim());
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值